New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update install docs (Core dependencies, Windows reqs, etc) #3769

Merged
merged 2 commits into from Sep 1, 2015

Conversation

Projects
None yet
3 participants
@chrisfinazzo
Contributor

chrisfinazzo commented Jun 9, 2015

No description provided.

@envygeeks

This comment has been minimized.

Show comment
Hide comment
@envygeeks

envygeeks Jun 9, 2015

Contributor

👍

Contributor

envygeeks commented Jun 9, 2015

👍

@envygeeks

This comment has been minimized.

Show comment
Hide comment
@envygeeks

envygeeks Jun 9, 2015

Contributor

Though I iterate again, since nodejs isn't required anymore maybe that should be updated in parallel.

Contributor

envygeeks commented Jun 9, 2015

Though I iterate again, since nodejs isn't required anymore maybe that should be updated in parallel.

@chrisfinazzo chrisfinazzo changed the title from Add Python to requirements for Jekyll 2 to Update install docs (Core dependencies, Windows reqs, etc) Jun 9, 2015

@chrisfinazzo

This comment has been minimized.

Show comment
Hide comment
@chrisfinazzo

chrisfinazzo Jun 9, 2015

Contributor

OK I'll update that. Is there a specific reason why nodejs is out for 3.0, or is this just part of the overall goal to slim things down? (Don't use Node, so I'm guessing)

As you indicated in #3768, the distinction needs to be made that many of the dependencies that Jekyll uses today are "opt-in" for 3.0.

Over time, those changes can land here.

Contributor

chrisfinazzo commented Jun 9, 2015

OK I'll update that. Is there a specific reason why nodejs is out for 3.0, or is this just part of the overall goal to slim things down? (Don't use Node, so I'm guessing)

As you indicated in #3768, the distinction needs to be made that many of the dependencies that Jekyll uses today are "opt-in" for 3.0.

Over time, those changes can land here.

envygeeks added a commit that referenced this pull request Sep 1, 2015

Merge pull request #3769 from chrisfinazzo/install-docs
Update install docs (Core dependencies, Windows reqs, etc)

@envygeeks envygeeks merged commit 0340fea into jekyll:master Sep 1, 2015

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@chrisfinazzo chrisfinazzo deleted the chrisfinazzo:install-docs branch Sep 23, 2015

@jekyll jekyll locked and limited conversation to collaborators Feb 27, 2017

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.