New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Invite to use Ruby > 2.1.0 in documentation #5983

Merged
merged 1 commit into from Mar 27, 2017

Conversation

Projects
None yet
4 participants
@DirtyF
Member

DirtyF commented Mar 26, 2017

Support for Ruby 2.0 has been dropped since #4381

This PR aims to state the current Ruby depency in the docs and on Rubygems.

Some core plugins could be impacted, for example jekyll/import still requires Ruby 1.9.x

/cc @jekyll/plugin-core

Show outdated Hide outdated jekyll.gemspec
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.specification_version = 2 if s.respond_to? :specification_version=
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.rubygems_version = "2.2.2"
s.required_ruby_version = ">= 2.0.0"
s.required_ruby_version = ">= 2.1.0"

This comment has been minimized.

@parkr

parkr Mar 27, 2017

Member

I'm fine with the documentation updates, but I'm 👎 on this change before Jekyll 4. Our policy on this has been:

  • Each major Jekyll version cannot remove support for old Ruby verisons by requiring newer ones in the gemspec. This is considered a breaking change.
  • Each minor Jekyll version can deprecate support for an old Ruby version by removing that Ruby version from CI and stating that support has been deprecated in the release blog post.
@parkr

parkr Mar 27, 2017

Member

I'm fine with the documentation updates, but I'm 👎 on this change before Jekyll 4. Our policy on this has been:

  • Each major Jekyll version cannot remove support for old Ruby verisons by requiring newer ones in the gemspec. This is considered a breaking change.
  • Each minor Jekyll version can deprecate support for an old Ruby version by removing that Ruby version from CI and stating that support has been deprecated in the release blog post.

This comment has been minimized.

@DirtyF

DirtyF Mar 27, 2017

Member

OK so Jekyll 4 can bump Ruby dependencies from 2.0 to 2.4 for instance, but Jekyll 3.5 cannot bump from 2.0 to 2.1, even if 2.0 is not tested anymore on CI.

PR updated accordingly.

@DirtyF

DirtyF Mar 27, 2017

Member

OK so Jekyll 4 can bump Ruby dependencies from 2.0 to 2.4 for instance, but Jekyll 3.5 cannot bump from 2.0 to 2.1, even if 2.0 is not tested anymore on CI.

PR updated accordingly.

@DirtyF DirtyF added this to the 4.0 milestone Mar 27, 2017

@parkr

parkr approved these changes Mar 27, 2017

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Mar 27, 2017

Member

Yeah, updating the required_ruby_version in the gemspec is a big deal and causes tons of headaches for people. Ruby 2.0 and 2.1 are basically compatible so it makes way more sense to me to just silently drop full support but still allow people to live dangerously and run Ruby 2.0 if they want.

Member

parkr commented Mar 27, 2017

Yeah, updating the required_ruby_version in the gemspec is a big deal and causes tons of headaches for people. Ruby 2.0 and 2.1 are basically compatible so it makes way more sense to me to just silently drop full support but still allow people to live dangerously and run Ruby 2.0 if they want.

@DirtyF

This comment has been minimized.

Show comment
Hide comment
@DirtyF

DirtyF Mar 27, 2017

Member

@jekyllbot: merge +docs

Member

DirtyF commented Mar 27, 2017

@jekyllbot: merge +docs

@jekyllbot jekyllbot merged commit 99f5925 into jekyll:master Mar 27, 2017

0 of 2 checks passed

continuous-integration/appveyor/pr AppVeyor build failed
Details
continuous-integration/travis-ci/pr The Travis CI build failed
Details

jekyllbot added a commit that referenced this pull request Mar 27, 2017

@DirtyF DirtyF deleted the DirtyF:ruby-2.1 branch Mar 27, 2017

@DirtyF DirtyF changed the title from Require Ruby > 2.1.0 to Invite to use Ruby > 2.1.0 in documentation Mar 27, 2017

Crissov added a commit to Crissov/jekyll that referenced this pull request Mar 27, 2017

parkr added a commit that referenced this pull request Mar 28, 2017

add /_data/*.tsv support (#5985)
* Update data.feature

- add .tsv
- add .csv with `\t`
- add .csv with `;`

* Fix Appveyor with dst-aware cucumber steps

* Check for given content in posts

* mention Ruby > 2.1.0 in docs

* Update history to reflect merge of #5983 [ci skip]

* Update history to reflect merge of #5961 [ci skip]

* Update data_reader.rb

- add .tsv support with tab separated columns
- not adding support for auto-detecting `:col_sep`

ftp://ftp.iana.org/assignments/media-types/text/tab-separated-values
https://www.ietf.org/rfc/rfc4180.txt (CSV)
https://ruby-doc.org/stdlib-2.4.1/libdoc/csv/rdoc/CSV.html

* Update data.feature

don't do semicolons and tabs in .csv within this patch

* Update data.feature

I don't know which component replaced my tab characters by space before.

* Update data.feature

t

* Update data_reader.rb

add a single space to satisfy format checker

@ashmaroli ashmaroli removed this from the 4.0 milestone Jan 23, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment