New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Adding DevKit helpers #6225

Merged
merged 1 commit into from Jul 25, 2017

Conversation

Projects
None yet
6 participants
@phocks
Contributor

phocks commented Jul 16, 2017

wdm requires the Ruby DevKit to install native extensions

Adding DevKit helpers
wdm requires the Ruby DevKit to install native extensions
@@ -212,5 +212,7 @@ As of v1.3.0, Jekyll uses the `listen` gem to watch for changes when the `--watc
Add the following to the Gemfile for your site if you have issues with auto-regeneration on Windows alone:
```ruby
gem 'wdm', '~> 0.1.0' if Gem.win_platform?
gem 'wdm', '~> 0.1.1' if Gem.win_platform?

This comment has been minimized.

@ashmaroli

ashmaroli Jul 16, 2017

Member

gem 'wdm', '~> 0.1.0' if Gem.win_platform? will automatically install the most recent version in 0.1.x series. So this change is unnecessary.

@ashmaroli

ashmaroli Jul 16, 2017

Member

gem 'wdm', '~> 0.1.0' if Gem.win_platform? will automatically install the most recent version in 0.1.x series. So this change is unnecessary.

This comment has been minimized.

@Crunch09

Crunch09 Jul 16, 2017

Member

It makes sense though if at least version 0.1.1 is needed. Given that in this version the installation with Ruby 2.2 apparently has been fixed (see wdm changelog) i think this update to the docs makes sense.

@Crunch09

Crunch09 Jul 16, 2017

Member

It makes sense though if at least version 0.1.1 is needed. Given that in this version the installation with Ruby 2.2 apparently has been fixed (see wdm changelog) i think this update to the docs makes sense.

This comment has been minimized.

@ashmaroli

ashmaroli Jul 16, 2017

Member

Ah! I see.. Thanks Florian 😃 👍

@ashmaroli

ashmaroli Jul 16, 2017

Member

Ah! I see.. Thanks Florian 😃 👍

```
You may first have to download and install the [Ruby DevKit](https://rubyinstaller.org/downloads/) by following [the instructions here](https://github.com/oneclick/rubyinstaller/wiki/Development-Kit).

This comment has been minimized.

@ashmaroli

ashmaroli Jul 16, 2017

Member

RubyInstaller is only for Ruby Versions upto those in v2.3. Those using Ruby 2.4.x and above will need to check out RubyInstaller2

@ashmaroli

ashmaroli Jul 16, 2017

Member

RubyInstaller is only for Ruby Versions upto those in v2.3. Those using Ruby 2.4.x and above will need to check out RubyInstaller2

@DirtyF

DirtyF approved these changes Jul 16, 2017

👍 Thanks!

@parkr

parkr approved these changes Jul 25, 2017

@parkr

This comment has been minimized.

Show comment
Hide comment
@parkr

parkr Jul 25, 2017

Member

@jekyllbot: merge +site

Member

parkr commented Jul 25, 2017

@jekyllbot: merge +site

@jekyllbot jekyllbot merged commit 93169f6 into jekyll:master Jul 25, 2017

2 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

jekyllbot added a commit that referenced this pull request Jul 25, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment