Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

export - special-characters not correct #599

Closed
JKoelman opened this issue Feb 15, 2014 · 5 comments

Comments

Projects
None yet
2 participants
@JKoelman
Copy link
Contributor

commented Feb 15, 2014

did add an event

  • created a title with special text
  • added event-description with characters

export is showing questions marks :(

@JKoelman JKoelman added this to the JEM 1.9.6 beta milestone Feb 15, 2014

@JKoelman JKoelman added the bug label Feb 15, 2014

@JKoelman JKoelman self-assigned this Feb 15, 2014

JKoelman added a commit that referenced this issue Feb 15, 2014

added BOM to model-export, REF #599
added bom to the model-export, this as multibyte/special characters were
not output correctly.
@JKoelman

This comment has been minimized.

Copy link
Contributor Author

commented Feb 15, 2014

should be working now (tried chinese + greek)

clipboard01

//
P.S. do like to point to this url as there was the fix mentioned:
http://www.skoumal.net/en/making-utf-8-csv-excel

@JKoelman

This comment has been minimized.

Copy link
Contributor Author

commented Feb 15, 2014

did notice that saving the file in Excel as Csv will blank/remove the characters.
(It's a common problem with Excel)

@JKoelman JKoelman closed this Feb 15, 2014

@Hoffi1

This comment has been minimized.

Copy link
Contributor

commented Feb 15, 2014

Sorry @JKoelman but I think it doesn't work.
Have exported to file and then imported untouched file back and see "???" instead of "你们好".
This is because text is exported as ANSI - and expected as ANSI on import. So it is generally consistent.
But ANSI doesn't support characters like "你们好" so they are changed to "???" on export.
So we should use UTF-8 for export/import. (which makes it incompatible to previous versions 😢 )

(I used a hex viewer to be sure)

@Hoffi1 Hoffi1 reopened this Feb 15, 2014

@Hoffi1

This comment has been minimized.

Copy link
Contributor

commented Feb 15, 2014

...have seen export model has changed - will text again...

@Hoffi1

This comment has been minimized.

Copy link
Contributor

commented Feb 15, 2014

...ok, export writes UTF-8 now (with bom). But import...

@Hoffi1 Hoffi1 closed this Feb 15, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.