Skip to content
Permalink
Browse files

[JENKINS-40810] Mention effect of Remoting 3 on Maven builds

  • Loading branch information
daniel-beck committed Jan 17, 2017
1 parent 09efc42 commit 1692ba554089a4281a8407372a51af5c3ef19db6
Showing with 3 additions and 0 deletions.
  1. +1 −0 content/changelog-stable/index.html
  2. +2 −0 content/doc/upgrade-guide/2.32.adoc
@@ -80,6 +80,7 @@ <h3><a name=v2.32.1>What's new in 2.32.1</a> (2016-12-24)</h3>
<li class="major rfe">
Upgrade Remoting to version 3.1 with <a href="https://github.com/jenkinsci/remoting/blob/master/docs/protocols.md#jnlp4-connect">JNLP4-connect protocol</a>.
<a href="https://github.com/jenkinsci/remoting/blob/master/docs/remoting-3-compatibility.md">Compatibility notes are available here</a>.
Notably, it is no longer possible to use JDK 6 for the Maven project type, as communication with the Maven process uses Remoting.
(<a href="https://issues.jenkins-ci.org/browse/JENKINS-37564">issue 37564</a>,
<a href="https://issues.jenkins-ci.org/browse/JENKINS-36871">issue 36871</a>,
<a href="https://issues.jenkins-ci.org/browse/JENKINS-37565">issue 37565</a>)
@@ -22,6 +22,8 @@ If that happens, set the System property `jenkins.slaves.DefaultJnlpSlaveReceive

https://wiki.jenkins-ci.org/display/JENKINS/Features+controlled+by+system+properties[Learn more about system properties in Jenkins.]

Additionally, this is the first remoting release that requires Java 7. While agents have needed Java 7 for a while now, remoting is also used to communicate with the Maven process in the Maven project type in the Maven Integration Plugin. These builds now needs a JDK 7 or newer to run. Use toolchains to compile with an older version of Java.

==== Administrative monitors are now shown on most pages

_Administrative monitors_ are the notifications only shown on the _Manage Jenkins_ page so far.

0 comments on commit 1692ba5

Please sign in to comment.
You can’t perform that action at this time.