Skip to content
Permalink
Browse files

Changelog: noting JENKINS-48761/JENKINS-48754 in Jenkins 2.100.

The PR also adds warning banners to 2.98/2.99
  • Loading branch information...
oleg-nenashev committed Jan 3, 2018
1 parent d23d79b commit ac42d83bf51e56e826991839a5471eccdd767543
Showing with 16 additions and 2 deletions.
  1. +16 −2 content/_data/changelogs/weekly.yml
@@ -1727,6 +1727,8 @@
Fix regression in 2.96 that caused a downgrade of Script Security when upgrading Jenkins.
- version: "2.98"
date: 2017-12-24
banner: >
The release introduced a serious regression (JENKINS-48761). We recommend upgrading to 2.100 or updating Remoting on agents to 3.15.
changes:
- type: major rfe
pull: 3145
@@ -1763,14 +1765,26 @@
# pull: 3161 benefit unclear
- version: "2.99"
date: 2017-12-31
banner: >
The release introduced a serious regression (JENKINS-48761). We recommend upgrading to 2.100 or updating Remoting on agents to 3.15.
changes:
- type: major bug
pull: 3196
issue: 21017
message: >
Updating Jenkins jobs and views by XML left fields at their old value if not defined in the new XML.
- version: "2.100"
date: 2018-01-03
changes:
- type: major bug
pull: 3212
message: >
Restore binary compatibility with agents running Remoting versions older than 3.15 (regression in 2.98).
references:
- issue: 48761
- issue: 48754
- url: https://groups.google.com/forum/#!topic/jenkinsci-dev/-VQ5YU0yYhg
title: Retrospective thread in the developer mailing list
# DO NOT EDIT THIS FILE DIRECTLY
# ALL CHANGES MUST GO THROUGH PULL REQUESTS
# MALFORMED FILE CONTENTS WILL BREAK THE SITE BUILD

0 comments on commit ac42d83

Please sign in to comment.
You can’t perform that action at this time.