Skip to content
Permalink
Browse files
[JENKINS-14901] set LD_LIBRARY_PATH for emulator to run on 64bit linux
  • Loading branch information
ndeloof committed Apr 2, 2013
1 parent e8c62cf commit c96a6d0d7c7744bc7836f25047d0fb23a3ed827a
Showing 1 changed file with 1 addition and 1 deletion.
@@ -126,7 +126,7 @@ public ProcStarter getProcStarter() throws IOException,
*/
public ProcStarter getProcStarter(ArgumentListBuilder command)
throws IOException, InterruptedException {
return getProcStarter().cmds(command);
return getProcStarter().cmds(command).envs("LD_LIBRARY_PATH=" + sdk.getSdkRoot() + "/tools/lib");
}

/**

1 comment on commit c96a6d0

@wuwu2000
Copy link

@wuwu2000 wuwu2000 commented on c96a6d0 Apr 7, 2016

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This blocks all 64 bit ABIs. You should revert this commit and add to manual something like "write in pre compile under 'Script Content' export LD_LIBRARY_PATH=/path/to/sdk/tools/lib(64):/usr/lib"
or you have to find the library path from ABI name.

This way the only way to override LD_LIBRARY_PATH is to edit the existing executable! You can not create a new executable and use this. Config UI of android_emulator plugin prevents this. This is no good.

Please sign in to comment.