Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Environment variables not correctly saved #553

Closed
CyrilSiman opened this issue Nov 12, 2017 · 7 comments
Closed

Environment variables not correctly saved #553

CyrilSiman opened this issue Nov 12, 2017 · 7 comments
Assignees
Labels
bug

Comments

@CyrilSiman
Copy link

@CyrilSiman CyrilSiman commented Nov 12, 2017

Hi,

Plugin version : 1.0.4
Jenkins : 2.73.3

During configuration, if I add an environment variable in node Properties, save global configuration and comeback in Jenkins Configure System panel, my variable is disappeared.

Step one : add a new variable

When I come back in panel a second time (none variable)

@fxnn

This comment has been minimized.

Copy link

@fxnn fxnn commented Nov 16, 2017

@alexeygrigorovaurea

This comment has been minimized.

Copy link

@alexeygrigorovaurea alexeygrigorovaurea commented Nov 23, 2017

I'm facing same issue

@vamsidhar5434

This comment has been minimized.

Copy link

@vamsidhar5434 vamsidhar5434 commented Nov 29, 2017

same problem to me as well

@ndeloof

This comment has been minimized.

Copy link
Member

@ndeloof ndeloof commented Dec 9, 2017

I can reproduce this issue, will investigate a fix for 1.1.1

@ndeloof ndeloof self-assigned this Dec 9, 2017
@ndeloof ndeloof added the bug label Dec 9, 2017
@fxnn

This comment has been minimized.

Copy link

@fxnn fxnn commented Dec 11, 2017

Still reproducible with 1.1.1 and Jenkins 2.93.

@ndeloof

This comment has been minimized.

Copy link
Member

@ndeloof ndeloof commented Dec 12, 2017

I've postponed fixing this, can't get repeatableHeteroProperty to work :'(

@ndeloof ndeloof closed this in c12a225 Dec 12, 2017
@fxnn

This comment has been minimized.

Copy link

@fxnn fxnn commented Dec 18, 2017

Confirming the fix with 1.1.2. Thank you!

gamma pushed a commit to gamma/docker-plugin that referenced this issue Dec 19, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.