Skip to content
Permalink
Browse files

[JENKINS-28120]

Now requiring Java7
  • Loading branch information
kohsuke committed Apr 29, 2015
1 parent 56d8d2d commit 9850770999541aff2e44e5695737a452892666d1
Showing with 2 additions and 2 deletions.
  1. +2 −2 src/main/java/Main.java
@@ -86,7 +86,7 @@ public static void main(String[] args) throws Exception {
String v = System.getProperty("java.class.version");
if (v!=null) {
try {
if (Float.parseFloat(v)<49.0f)
if (Float.parseFloat(v)<51.0f)
throw new UnsupportedClassVersionError(v);
} catch (NumberFormatException e) {
// err on the safe side and keep on going
@@ -97,7 +97,7 @@ public static void main(String[] args) throws Exception {

_main(args);
} catch (UnsupportedClassVersionError e) {
System.err.println("Jenkins requires Java5 or later, but you are running "+
System.err.println("Jenkins requires Java7 or later, but you are running "+
System.getProperty("java.runtime.version")+" from "+System.getProperty("java.home"));
e.printStackTrace();
}

0 comments on commit 9850770

Please sign in to comment.
You can’t perform that action at this time.