Skip to content
Permalink
Browse files
[JENKINS-27171] Displays compatibility warnings in the update center …
…for flexible-publish < 0.15.
  • Loading branch information
ikedam committed Mar 29, 2015
1 parent f4c0283 commit bc5e694170d0a3d1f52955634e1fa8cfbd718210
Showing 1 changed file with 13 additions and 0 deletions.
13 pom.xml
@@ -63,6 +63,19 @@
</developer>
</developers>

<build>
<plugins>
<plugin>
<groupId>org.jenkins-ci.tools</groupId>
<artifactId>maven-hpi-plugin</artifactId>
<extensions>true</extensions>
<configuration>
<compatibleSinceVersion>0.15</compatibleSinceVersion>
</configuration>
</plugin>
</plugins>
</build>

<dependencies>
<dependency>
<groupId>org.jenkins-ci.plugins</groupId>

3 comments on commit bc5e694

@KostyaSha
Copy link
Member

@KostyaSha KostyaSha commented on bc5e694 Mar 29, 2015

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

👎 for such plugin maintaining. Configurations broken without any reason.

@daniel-beck
Copy link
Member

@daniel-beck daniel-beck commented on bc5e694 Mar 29, 2015

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@KostyaSha Would you prefer that users will be surprised by the change? I cannot conceive of a single reason to object to telling users this way that something changed. (Note that this is different from objecting to the incompatible change itself, but that is implemented and discussed elsewhere.)

@KostyaSha
Copy link
Member

@KostyaSha KostyaSha commented on bc5e694 Mar 30, 2015

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

@daniel-beck this is summary in general for @ikedam maintaining. I will prefer to revert last 2 releases and decline https://groups.google.com/forum/?hl=en#!searchin/jenkinsci-dev/flexible-publish/jenkinsci-dev/ovlA2DbwUa8/8jpl-gZs9RMJ .

Please sign in to comment.