Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Updated versions in pom.xml #64

Merged
merged 1 commit into from Jun 26, 2012

Conversation

Projects
None yet
4 participants
Member

marc-guenther commented Apr 5, 2012

Some dependencies were quite old, and this plugin would not even run correctly when doing a simple mvn hpi:run

  • updated jenkins to latest version 1.458
  • updated token-macro to 1.1 to avoid cyclic dependence warning. That version is also used in the jenkins poms
  • set the dependency on the com.infradna.tool.bridge-method-injector plugin to the latest 1.4 to avoid a maven warning
Member

mfriedenhagen commented Apr 5, 2012

May I suggest depending on the last LTS version instead? Or maybe the rc1
of the next LTS?

Regards Mirko

Sent from my phone
http://illegalstateexception.blogspot.com
http://github.com/mfriedenhagen/
https://bitbucket.org/mfriedenhagen/
On Apr 5, 2012 5:25 PM, "marc-guenther" <
reply@reply.github.com>
wrote:

Member

ndeloof commented Apr 7, 2012

if plugin works fine on 1.409 (LTS), and don't require new API, I can't see a reason to upgrade to another LTS, so that it is still available for "old" jenkins installations

Member

marc-guenther commented Apr 10, 2012

I changed the jenkins version back to 1.409, cause the change was not needed.

The real problem was with the token-macro plugin, which was set to 1.0. This caused all the problems. Changing it to 1.1 should also fix almost all of the unit test problems.

@marc-guenther marc-guenther fixed two versions in the pom.xml
- updated token-macro from 1.0 to 1.1
- set the bridge-method-injector from undefined to 1.4

The token-macro change should also fix lots of problems
with the unit tests.
068cee0

@kohsuke kohsuke merged commit 068cee0 into jenkinsci:master Jun 26, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment