Skip to content
Permalink
Browse files

[JENKINS-50838] Change GitLab API support from v3 to v4.

  • Loading branch information
MarioSteinitz committed Apr 26, 2018
1 parent 268a0d6 commit 3ab60a7802059b0c53556c61132d234dc2b31310
@@ -72,7 +72,7 @@
<dependency>
<groupId>org.gitlab</groupId>
<artifactId>java-gitlab-api</artifactId>
<version>1.2.6</version>
<version>4.0.0</version>
</dependency>
<dependency>
<groupId>org.jenkins-ci</groupId>
@@ -268,7 +268,7 @@ public Boolean call() throws Exception {
// could be non-existant)
return Boolean.FALSE;
} else {
return Boolean.valueOf(repository.isPublic());
return repository.isPublic();
}
}
});
@@ -2,7 +2,7 @@
<p>
Normally this value stays as-is. If you are using <b><a href="https://enterprise.gitlab.com">GitLab Enterprise</a></b>
then you should enter the URI to the <strong>API</strong> root of your GitLab installation
(e.g. <b>https://gitlab.company.com</b>. The plugin will automatically add "api/v3" suffix for you.).
(e.g. <b>https://gitlab.company.com</b>. The plugin will automatically add "api/v4" suffix for you.).
<p/>

Notes:

0 comments on commit 3ab60a7

Please sign in to comment.
You can’t perform that action at this time.