Skip to content
Permalink
Browse files
[FIXED JENKINS-32589] Dependency to workflow-plugin should be optional.
  • Loading branch information
ikedam committed Jan 25, 2016
1 parent 7df1063 commit eb95585cf4c789504869515391f7cad7adac8458
Showing with 2 additions and 1 deletion.
  1. +1 −0 pom.xml
  2. +1 −1 src/main/java/org/jvnet/hudson/plugins/groovypostbuild/WorkflowManager.java
@@ -83,6 +83,7 @@
<groupId>org.jenkins-ci.plugins.workflow</groupId>
<artifactId>workflow-cps</artifactId>
<version>${workflow.version}</version>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.jenkins-ci.plugins.workflow</groupId>
@@ -37,7 +37,7 @@
/**
* Exposes {@link org.jvnet.hudson.plugins.groovypostbuild.GroovyPostbuildRecorder.BadgeManager} to Workflow scripts as {@code manager}.
*/
@Extension
@Extension(optional=true)
public class WorkflowManager extends GlobalVariable {

@Override

0 comments on commit eb95585

Please sign in to comment.