Skip to content
Permalink
Browse files

JENKINS-41515:

* Update Jenkins parent to 1.625.3 to be able to test with current pipeline-plugin
* Adjust dependencies and add some exclusions to remove a number of unnecessary jars from the resulting hpi file
  • Loading branch information...
centic9 committed Mar 24, 2017
1 parent 84c070d commit 4baa40f8fb07cda1159880769e0f92024183d152
Showing with 41 additions and 7 deletions.
  1. +41 −7 pom.xml
48 pom.xml
@@ -28,7 +28,7 @@ THE SOFTWARE.
<parent>
<groupId>org.jenkins-ci.plugins</groupId>
<artifactId>plugin</artifactId>
<version>1.614</version>
<version>1.625.3</version>
<relativePath />
</parent>

@@ -121,6 +121,12 @@ THE SOFTWARE.
<artifactId>dashboard-view</artifactId>
<version>2.1</version>
<optional>true</optional>
<exclusions>
<exclusion>
<groupId>net.sourceforge.nekohtml</groupId>
<artifactId>*</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.jacoco</groupId>
@@ -145,11 +151,12 @@ THE SOFTWARE.
<version>5.0.1</version>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
<version>3.4</version>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
<version>3.4</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.powermock</groupId>
<artifactId>powermock-module-junit4</artifactId>
@@ -166,7 +173,22 @@ THE SOFTWARE.
<groupId>org.jacoco</groupId>
<artifactId>jacoco-maven-plugin</artifactId>
<version>${jacoco.version}</version>
</dependency>
<!-- Exclude a few unused transitive dependencies of things that are not needed here to avoid clashes with other plugins -->
<exclusions>
<exclusion>
<groupId>org.apache.maven.doxia</groupId>
<artifactId>*</artifactId>
</exclusion>
<exclusion>
<groupId>backport-util-concurrent</groupId>
<artifactId>*</artifactId>
</exclusion>
<exclusion>
<groupId>org.codehaus.plexus</groupId>
<artifactId>*</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-plugin-plugin</artifactId>
@@ -202,6 +224,18 @@ THE SOFTWARE.
<artifactId>plexus-utils</artifactId>
<version>3.0.24</version>
</dependency>
<!-- Somehow we need org.w3c.dom.ElementTraversal, but do not get it from any of the dependencies
do not update to 2.x as it will not contain the class any more! -->
<dependency>
<groupId>xml-apis</groupId>
<artifactId>xml-apis</artifactId>
<version>1.4.01</version>
</dependency>
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpcore</artifactId>
<version>4.4.1</version>
</dependency>
</dependencies>

<distributionManagement>

0 comments on commit 4baa40f

Please sign in to comment.
You can’t perform that action at this time.