Skip to content
Permalink
Browse files

[JENKINS-21486] Fix up messages and show plugin version

  • Loading branch information...
Vlatombe committed Jul 28, 2016
1 parent 99fa5f7 commit 6bf02d514d80e806f108290fbea06ac6f6064798
@@ -576,7 +576,7 @@ public boolean hasLicensesXml() {
if (dependency == null) {
PluginWrapper failedDependency = NOTICE.getPlugin(d.shortName);
if (failedDependency != null) {
dependencyErrors.add(Messages.PluginWrapper_failed_to_load(failedDependency.getLongName(), d.version));
dependencyErrors.add(Messages.PluginWrapper_failed_to_load_dependency(failedDependency.getLongName(), d.version));
break;
} else {
dependencyErrors.add(Messages.PluginWrapper_missing(d.shortName, d.version));
@@ -610,7 +610,7 @@ public boolean hasLicensesXml() {
if (!dependencyErrors.isEmpty()) {
NOTICE.addPlugin(this);
StringBuilder messageBuilder = new StringBuilder();
messageBuilder.append("Failed to load ").append(getLongName()).append(System.lineSeparator());
messageBuilder.append(Messages.PluginWrapper_failed_to_load_plugin(getLongName(), getVersion())).append(System.lineSeparator());
for (Iterator<String> iterator = dependencyErrors.iterator(); iterator.hasNext(); ) {
String dependencyError = iterator.next();
messageBuilder.append(" - ").append(dependencyError);
@@ -73,10 +73,11 @@ ProxyConfiguration.Success=Success

Functions.NoExceptionDetails=No Exception details

PluginWrapper.missing=Plugin "{0}" ({1}) is missing. To fix, install version {1} or later.
PluginWrapper.failed_to_load=Plugin "{0}" ({1}) failed to load. Fix this plugin first.
PluginWrapper.disabledAndObsolete=Plugin "{0}" ({1}) is disabled and older than required. To fix, install version {2} or later and enable it.
PluginWrapper.disabled=Plugin "{0}" is disabled. To fix, enable it.
PluginWrapper.obsolete=Plugin "{0}" ({1}) is older than required. To fix, install version {2} or later.
PluginWrapper.obsoleteCore=You must update Jenkins from {0} to version {1} or later to run this plugin.
PluginWrapper.missing={0} v{1} is missing. To fix, install v{1} or later.
PluginWrapper.failed_to_load_plugin={0} v{1} failed to load.
PluginWrapper.failed_to_load_dependency={0} v{1} failed to load. Fix this plugin first.
PluginWrapper.disabledAndObsolete={0} v{1} is disabled and older than required. To fix, install v{2} or later and enable it.
PluginWrapper.disabled={0} is disabled. To fix, enable it.
PluginWrapper.obsolete={0} v{1} is older than required. To fix, install v{2} or later.
PluginWrapper.obsoleteCore=You must update Jenkins from v{0} to v{1} or later to run this plugin.
TcpSlaveAgentListener.PingAgentProtocol.displayName=Ping protocol
@@ -9,7 +9,7 @@
There are dependency errors loading some plugins:
<ul>
<j:forEach items="${it.plugins}" var="plugin">
<li>${plugin.longName}
<li>${plugin.longName} v${plugin.version}
<ul>
<j:forEach items="${plugin.dependencyErrors}" var="d">
<li>${d}</li>

0 comments on commit 6bf02d5

Please sign in to comment.
You can’t perform that action at this time.