Skip to content
Permalink
Browse files

Updating Guava.

I found that literate-api library wants to use a newer version of Guava.
Sine all the usage of Guava in plugins end up picking up the version
from core, we need to rev this pretty aggressively.
  • Loading branch information...
kohsuke committed Oct 16, 2013
1 parent afea2a5 commit d45d18ed4e43057c42c363fe306f3945113f8f80
Showing with 2 additions and 2 deletions.
  1. +1 −1 core/src/main/java/hudson/util/RunList.java
  2. +1 −1 pom.xml
@@ -133,7 +133,7 @@ public R get(int index) {
public List<R> subList(int fromIndex, int toIndex) {
List<R> r = new ArrayList<R>();
Iterator<R> itr = iterator();
Iterators.skip(itr,fromIndex);
Iterators.advance(itr,fromIndex);
for (int i=toIndex-fromIndex; i>0; i--) {
r.add(itr.next());
}
@@ -179,7 +179,7 @@ THE SOFTWARE.
<dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
<version>11.0.1</version>
<version>15.0</version>
</dependency>

<dependency>

0 comments on commit d45d18e

Please sign in to comment.
You can’t perform that action at this time.