New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Require at least Java 8u101 for the updates.jenkins.io certs #3015

Merged
merged 1 commit into from Sep 15, 2017

Conversation

3 participants
@daniel-beck
Member

daniel-beck commented Sep 10, 2017

Downstream from #2996: If we keep that around (I'm not convinced that's the best approach TBH), let's enforce jenkins-war is built by 8u101 or newer, otherwise it will just be annoying to debug it.

Not sure this is a good idea to do (it's unnecessary for actual building), feedback welcome.

@jenkinsci/code-reviewers

@batmat

batmat approved these changes Sep 11, 2017

Can't see why we shouldn't be more aggressive with it to avoid issues, even if possibly unlikely.

@oleg-nenashev

This comment has been minimized.

Show comment
Hide comment
@oleg-nenashev

oleg-nenashev Sep 11, 2017

Member

We also need to check the bundled Java version in Windows Packages, etc.
FUN

Member

oleg-nenashev commented Sep 11, 2017

We also need to check the bundled Java version in Windows Packages, etc.
FUN

@oleg-nenashev

This comment has been minimized.

Show comment
Hide comment
@oleg-nenashev

oleg-nenashev Sep 15, 2017

Member

There is no votes against, so I am going to just merge it. BTW, I would consider reverting #2996 since we are not sure that all other stock 1,8 JVMs support Let's Encrypt

Member

oleg-nenashev commented Sep 15, 2017

There is no votes against, so I am going to just merge it. BTW, I would consider reverting #2996 since we are not sure that all other stock 1,8 JVMs support Let's Encrypt

@oleg-nenashev oleg-nenashev merged commit b3fa926 into jenkinsci:master Sep 15, 2017

1 check passed

continuous-integration/jenkins/pr-head This commit looks good
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment