Skip to content
Permalink
Browse files

[JENKINS-29922] @aheritier requests some information about version av…

…ailability.
  • Loading branch information...
jglick committed Aug 5, 2016
1 parent 50af0b6 commit d234db971a021ef58271f2e2724f1debd1d4f54f
Showing with 3 additions and 0 deletions.
  1. +3 −0 TUTORIAL.md
@@ -314,6 +314,9 @@ Newer versions of Pipeline will often allow shorter forms, such as
archiveArtifacts artifacts: '**/target/*.jar', fingerprint: true
```

_Pipeline: Groovy_ 2.10 or later is needed for such syntax.
Depending on the particular call, you may also need _Pipeline: Basic Steps_ 2.1 or later,
Jenkins core 2.2 or later, and/or updated versions of various Pipeline-compatible plugins.
See the _Pipeline Syntax: Reference_ page inside Jenkins for a detailed guide on step configuration syntax.

**Example**: rather than using the simple `git` step, you can use the more general `checkout` step and specify any complex configuration supported by the Git plugin:

1 comment on commit d234db9

@aheritier

This comment has been minimized.

Copy link
Member

aheritier commented on d234db9 Aug 5, 2016

perfect @jglick

Please sign in to comment.
You can’t perform that action at this time.