Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cloudmatic Reverse Proxy dysfunctional in latest release (3.45.5.20190330) #589

Closed
mike-bee opened this issue Apr 3, 2019 · 11 comments

Comments

Projects
None yet
3 participants
@mike-bee
Copy link

commented Apr 3, 2019

Describe the bug

  1. The Cloudmatic reverse proxy service does not start automatically after (re)start of RaspberryMatic since I am using it (starting from 2.27.8.20170501).
  2. Since release 3.45.5.20190330 the service does not work anymore at all.

To Reproduce
Steps to reproduce the behavior:

  1. Subscribe to "Cloudmatic connect" service
  2. Register a network device under "Einstellungen/Netzwerkgeräte" at cloudmatic.de
  3. Click on "DIENST BEENDEN"/"DIENST STARTEN" unter "Dienste" in the WebUI of the "Cloudmatic"-AddOn (to workaround bug 1)
  4. Try to access your network device over VPN using a browser link like "https://YourCloudmaticId.meine-homematic.de:YourPort" (to reproduce bug 2)
  5. See error message "502 Bad Gateway, openresty/1.9.3.1"

Expected behavior
Secure access to your network device through the Cloudmatic VPN channel

Screenshots

System information (please complete the following information):

  • RaspberryMatic 3.45.5.20190330
  • RaspberryPi3+

Additional context

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Apr 4, 2019

Can you please try to completely disable/delete the add-on and reinit it again. My current guess is, that then the reverse proxy functionality will start working again as the user directory of the add-on will then be refreshed accordingly and the correct binaries being installed so that the reverse proxy can be started again.

@mike-bee

This comment has been minimized.

Copy link
Author

commented Apr 4, 2019

Sure. But can you please be a bit more specific? As Cloudmatic is integral part of the image it can't be disable/deleted via WebUI (or I simply don't know). So I guess I have to use the command line. Not being a Lunix guru I will need some support here.

@mike-bee mike-bee closed this Apr 4, 2019

@Matten-Matten

This comment has been minimized.

Copy link

commented Apr 4, 2019

Moin, auch ich habe das Problem. Ich hab sogar Den Cloudmatic Support via TeamV. auf meiner RM gelassen...

Auch ich werde das, was eben von J. Maus empfohlen wurde testen.

sollte aber alles nicht funktionieren hab ich vom Cloudmatic Support den Tipp bekommen wie ich
den via "root" Login manuell starten kann:

im Verzeichnis:
/etc/config/addons/mh

folgendes ausführen:
./dienstanngx.sh

Gruß
Matten Matten

@mike-bee

This comment has been minimized.

Copy link
Author

commented Apr 4, 2019

Oops, accidentally closed.

@mike-bee mike-bee reopened this Apr 4, 2019

@Matten-Matten

This comment has been minimized.

Copy link

commented Apr 4, 2019

@jens-maus

bei mir hat es nicht funktioniert.

Ich bin auf das Cloudmatic Addon gegangen habe den reiter "entfernen" ausgewählt und dann auf Daten löschen.
Danach hab ich den Schlüssel wieder auf die RM geladen, den Reverse Proxy Dienst gestartet, aber ohne erfolg.
Auch ich habe keine Ahnung wie man das Cloudmatic Addon vollständig löscht!?

@jens-maus

This comment has been minimized.

Copy link
Owner

commented Apr 4, 2019

@Matten-Matten Das kannst du tun in dem du wie folg vorgehst:

  1. CloudMatic Daten alle Löschen (wie vorher)
  2. Dann in der Kommandozeile folgenden Befehl ausführen: rm -rf /etc/config/addons/mh
  3. Danach Neustarten und das CloudMatic komplett neu einrichten.
@Matten-Matten

This comment has been minimized.

Copy link

commented Apr 4, 2019

Ok also wird das was ich mit der Kommandozeile lösche automatisch bei einen neustart wiedergeholt?
Ich teste das.

@Matten-Matten

This comment has been minimized.

Copy link

commented Apr 4, 2019

ok,
/etc/config/addons/mh gelöscht

RM bootet gerde neu. ich habe den neustart über die Weboberfäche gemacht. ich hoffe das war richtig...

@Matten-Matten

This comment has been minimized.

Copy link

commented Apr 4, 2019

leider ohne Erfolg.

@mike-bee

This comment has been minimized.

Copy link
Author

commented Apr 5, 2019

Same here.

@mike-bee mike-bee changed the title Cloudmatic Revers Proxy dysfunctional in latest release (3.45.5.20190330) Cloudmatic Reverse Proxy dysfunctional in latest release (3.45.5.20190330) Apr 6, 2019

@mike-bee

This comment has been minimized.

Copy link
Author

commented Apr 11, 2019

Hi Jens
The issue is labeled "awaiting feedback". Is there anything you need from me (us) to resolve this one?
Thanks
MikeBee

@jens-maus jens-maus added this to the 3.45.7.20190511 milestone May 7, 2019

@jens-maus jens-maus closed this in c8ffe8c May 7, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.