Permalink
Browse files

* misc: final YAM 2.6p1 release preparations.

* YAM.c: bumped all minimum required versions of all required mcc classes
  and libraries to the latest versions.
  • Loading branch information...
jens-maus committed Sep 26, 2010
1 parent 6fe399b commit 80710f50278fec7eb06521c2a14cfae18208d03e
Showing with 59 additions and 19 deletions.
  1. +8 −0 ChangeLog
  2. +39 −7 doc/ReadMe
  3. +11 −11 src/YAM.c
  4. +1 −1 src/tools/mkrelease.sh
@@ -5,6 +5,14 @@ YAM Open Source - ChangeLog
$Id$
$URL$
#### YAM 2.6p1 RELEASE ##################################################
2010-09-26 Jens Langner <Jens.Langner@light-speed.de>
* misc: final YAM 2.6p1 release preparations.
* YAM.c: bumped all minimum required versions of all required mcc classes
and libraries to the latest versions.
2010-09-21 P�r Boberg <pbobbenb@spray.se>
* doc/Install-YAM: updated the swedish section of the script.
@@ -1,14 +1,14 @@
Short: YAM 2.6 - MUI-based E-mail client
Short: YAM 2.6p1 - MUI-based E-mail client
Author: YAM Open Source Team (http://www.yam.ch/)
Uploader: Jens Langner <Jens.Langner@light-speed.de>
Type: comm/yam
Version: 2.6
Replaces: comm/yam/YAM25*
Version: 2.6p1
Replaces: comm/yam/YAM26*
Requires: AmigaOS 3.0+, MorphOS or AROS, MUI 3.8+, 68020+/PPC604e+
Architecture: ppc-amigaos >= 4.0.5; m68k-amigaos >= 3.0; ppc-morphos >= 1.4.2; i386-aros; ppc-aros; x86_64-aros
---------------------------------------------------------------------------
YAM - Version 2.6
YAM - Version 2.6p1
---------------------------------------------------------------------------
About YAM
@@ -28,7 +28,7 @@ year 2000 a group of mixed developers maintain YAM and release new versions
from time to time. While these versions are all targeted for the Amiga
platform, versions of different AmigaOS incarnations are supplied. This
includes native PowerPC ports to modern Amiga platforms like AmigaOS4 or
MorphOS.
MorphOS. But also releases for the AmigaOS reimplementation project AROS.
Before you start the installation
@@ -55,19 +55,51 @@ Afterwards you may manually import the mails from your old installation.
What's new
----------
Here's a list (in alphabetical order) of the brave developers who have
contributed to this release since the last official one:
contributed to the 2.6 release line up to now:
Alexey Ivanov
David Rey
Guenther Nikl
Frank Weber
Jens Langner
Joerg Strohmayer
Matthias Rustler
Olaf Barthel
Thore Boeckelmann
And here's a PARTIAL list of the changes in this version with respect to
the previous official update:
the previous official update (2.5):
YAM 2.6p1 (bugfix release):
- improved general stability by having fixed several memory leaks, important
bugs and situations where YAM crashed under certain circumstances.
- fixed the tons of "empty" themes warnings in case NOIMAGEWARNING tooltype
or a themes "NoImageWarning" option is set.
- fixed the "Jump on XXX" config settings to better interact with each other.
- fixed keyboard usage (cursor left/right) to switch between the folder and
mail list.
- fixed some endianess cases so that the AROS build for i386 works more
smoothly.
- fixed the spam filter to handle its 'inactive' state better and not reset
all values anymore on that occassion. Now it is possibile to turn off
the SPAM filter all together.
- fixed display of the poppen objects for MUI 3.8 installations.
- the attachment show window will now display the mail part description
in a separate column.
- fixed problems with important mails containing X-Status: and Status:
as local headers.
- fixed bug in the "avoid duplicates" functionality which caused that
not all mails have been shown in a preselection window.
- updated the included AISS based theme to require at least AISS 4.8
- fixed the mail attachment management to not use internal file names
for the "Content-Disposition" header of attachments.
- fixed mail search functionality to correctly handle mail header searches.
- fixed XPK packer scanning to show all installed packers correctly.
- fixed the startup to handle multi user installation more smoothly.
- fixed the installation script to get the installation going again.
YAM 2.6:
- updated translations for czech, french, german, greek, italian and swedish
language.
@@ -1862,7 +1862,7 @@ static void InitBeforeLogin(BOOL hidden)
INITLIB("openurl.library", 1, 0, &OpenURLBase, "main", 1, &IOpenURL, FALSE, NULL);
// try to open the mandatory codesets.library
INITLIB("codesets.library", 6, 8, &CodesetsBase, "main", 1, &ICodesets, TRUE, "http://www.sf.net/projects/codesetslib/");
INITLIB("codesets.library", 6, 12, &CodesetsBase, "main", 1, &ICodesets, TRUE, "http://www.sf.net/projects/codesetslib/");
// try to open expat.library for our XML import stuff
INITLIB("expat.library", XML_MAJOR_VERSION, 0, &ExpatBase, "main", 1, &IExpat, FALSE, NULL);
@@ -1892,23 +1892,23 @@ static void InitBeforeLogin(BOOL hidden)
#endif
// Lets check for the correct TheBar.mcc version
CheckMCC(MUIC_TheBar, 26, 2, TRUE, "http://www.sf.net/projects/thebar/");
CheckMCC(MUIC_TheBarVirt, 26, 2, TRUE, "http://www.sf.net/projects/thebar/");
CheckMCC(MUIC_TheButton, 26, 2, TRUE, "http://www.sf.net/projects/thebar/");
CheckMCC(MUIC_TheBar, 26, 7, TRUE, "http://www.sf.net/projects/thebar/");
CheckMCC(MUIC_TheBarVirt, 26, 7, TRUE, "http://www.sf.net/projects/thebar/");
CheckMCC(MUIC_TheButton, 26, 7, TRUE, "http://www.sf.net/projects/thebar/");
// Lets check for the correct BetterString.mcc version
CheckMCC(MUIC_BetterString, 11, 16, TRUE, "http://www.sf.net/projects/bstring-mcc/");
CheckMCC(MUIC_BetterString, 11, 20, TRUE, "http://www.sf.net/projects/bstring-mcc/");
// we also make sure the user uses the latest brand of all other NList classes, such as
// NListview, NFloattext etc.
CheckMCC(MUIC_NList, 20, 121, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NListview, 19, 76, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NFloattext, 19, 57, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NListtree, 18, 28, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NBalance, 15, 2, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NList, 20, 127, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NListview, 19, 82, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NFloattext, 19, 63, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NListtree, 18, 34, TRUE, "http://www.sf.net/projects/nlist-classes/");
CheckMCC(MUIC_NBalance, 15, 8, TRUE, "http://www.sf.net/projects/nlist-classes/");
// Lets check for the correct TextEditor.mcc version
CheckMCC(MUIC_TextEditor, 15, 28, TRUE, "http://www.sf.net/projects/texteditor-mcc/");
CheckMCC(MUIC_TextEditor, 15, 36, TRUE, "http://www.sf.net/projects/texteditor-mcc/");
// initialize the thread system of YAM
if(InitThreads() == FALSE)
@@ -77,7 +77,7 @@ cp ../doc/ReadMe_gallery "release/$yamsys/YAM $yamver/Gallery/ReadMe"
cp ../icons/$1/ReadMe.info "release/$yamsys/YAM $yamver/Gallery/ReadMe.info"
echo " MK $yamsys/Install"
mkdir -p "release/$yamsys/YAM $yamver/Install"
cp -r "../../../distribution/$yamsys/YAM $yamver/Install/" "release/$yamsys/YAM $yamver/"
svn --force export "https://svn.yam.ch/svn/yam/distribution/$yamsys/YAM%20$yamver/Install/" "release/$yamsys/YAM $yamver/Install/"
cp ../icons/$1/Install_directory.info "release/$yamsys/YAM $yamver/Install.info"
cp ../doc/Install-YAM "release/$yamsys/YAM $yamver/Install/Install-YAM"
cp ../icons/$1/Install-YAM.info "release/$yamsys/YAM $yamver/Install/Install-YAM.info"

0 comments on commit 80710f5

Please sign in to comment.