Permalink
Commits on Jan 2, 2008
  1. Version 1.0.

    ciconia committed Jan 2, 2008
  2. almost there.

    ciconia committed Jan 2, 2008
  3. oops. not there yet.

    ciconia committed Jan 2, 2008
  4. on the way...

    ciconia committed Jan 2, 2008
  5. intermediate step

    ciconia committed Jan 2, 2008
  6. Rearranged trunk.

    ciconia committed Jan 2, 2008
  7. In preparation for 1.0.

    ciconia committed Jan 2, 2008
  8. added doc dir.

    ciconia committed Jan 2, 2008
Commits on Jan 1, 2008
  1. Created sequel wrapper gem. Bundles sequel_core and sequel_model as d…

    ciconia committed Jan 1, 2008
    …ependencies. In preparation for release 1.0.
  2. Fixed error behavior when parse_tree or ruby2ruby are not available. …

    ciconia committed Jan 1, 2008
    …Fixed error behavior when sequel_model is not available. 100% code coverage.
  3. Improved code coverage - now at 99.2%. Fixed String#to_time to raise …

    ciconia committed Jan 1, 2008
    …error correctly for invalid time stamps. Version 0.5.0.2.
  4. Fixed issues #111, #112.

    ciconia committed Jan 1, 2008
  5. Refactored hooks code. Hooks are now inheritable, and can be defined …

    ciconia committed Jan 1, 2008
    …by supplying a block or a method name, or by overriding the hook instance method. Hook chains can now be broken by returning false.
Commits on Dec 31, 2007
  1. Version 0.5.0.1.

    ciconia committed Dec 31, 2007
  2. fix typo in rdoc (thanks Inviz)

    Aman Gupta committed Dec 31, 2007
Commits on Dec 30, 2007
  1. * Removed LoadError trap from bin/sequel.

    codahale committed Dec 30, 2007
    * Replaced Sequel::Error::InvalidDatabaseScheme with Sequel::Error::AdapterNotFound.
    * Sequel::Database.adapter_class now raises an AdapterNotFound exception if the adapter file can't be found or if the adapter isn't contained in the file.
  2. update validations spec (no LoadError anymore, and fixed invalid usag…

    Aman Gupta committed Dec 30, 2007
    …e of pending in specs)
  3. remove warnings about validatable gem since it is now a dependency of…

    Aman Gupta committed Dec 30, 2007
    … sequel_model
  4. ParseTree on win32 requires PT2.1.1 and RI3.6.6

    Aman Gupta committed Dec 30, 2007
Commits on Dec 26, 2007
  1. Fixed Rakefile.

    ciconia committed Dec 26, 2007
  2. Removed old spec.

    ciconia committed Dec 26, 2007
  3. Removed old stuff.

    ciconia committed Dec 26, 2007
  4. Added general Rakefile.

    ciconia committed Dec 26, 2007
Commits on Dec 25, 2007
  1. new_trunk branch.

    ciconia committed Dec 25, 2007
  2. Updated Rakefile, small stuff.

    ciconia committed Dec 25, 2007
  3. Version 0.4.5.

    ciconia committed Dec 25, 2007