pg_auto_parameterize extension prevents usage of cursors. #463

Closed
chanks opened this Issue Apr 3, 2012 · 3 comments

Comments

Projects
None yet
2 participants
Contributor

chanks commented Apr 3, 2012

Example: https://gist.github.com/2289822

Thank you!

Edit: Ha! My gist id is a palindrome!

Owner

jeremyevans commented Apr 3, 2012

I don't plan on supporting cursors in the pg_auto_parameterize extension, but I will add a note to the documentation that mentions explicitly that cursors are not supported.

Owner

jeremyevans commented Apr 3, 2012

Actually, there's a fairly easy fix for this, just disabling auto parameterization if you use use_cursor. I'll be pushing a commit shortly that does that.

Contributor

chanks commented Apr 3, 2012

Cool, thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment