win10, atom v1.0.13, terminal-plus v0.4.3 not working #15

Closed
zaaack opened this Issue Sep 19, 2015 · 95 comments

Comments

Projects
None yet
@zaaack

zaaack commented Sep 19, 2015

360 177806018311879

after successfully installed, it just don't show anything and can't type any commands. There are no error message either. But I have to say it could be the best terminal plugin in atom-windows

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 19, 2015

Owner

Please try uninstalling and then reinstalling the app. Don't worry, your
settings shouldn't disappear.

On Fri, Sep 18, 2015, 9:05 PM Z.Y. notifications@github.com wrote:

[image: 360 177806018311879]
https://cloud.githubusercontent.com/assets/5233940/9974539/30a4d922-5ec6-11e5-8ecf-af67099e301f.png

after successfully installed, it just don't show anything and can't type
any commands. There are no error message either. But I have to say it could
be the best terminal plugin in atom-windows


Reply to this email directly or view it on GitHub
#15.

Owner

jeremyramin commented Sep 19, 2015

Please try uninstalling and then reinstalling the app. Don't worry, your
settings shouldn't disappear.

On Fri, Sep 18, 2015, 9:05 PM Z.Y. notifications@github.com wrote:

[image: 360 177806018311879]
https://cloud.githubusercontent.com/assets/5233940/9974539/30a4d922-5ec6-11e5-8ecf-af67099e301f.png

after successfully installed, it just don't show anything and can't type
any commands. There are no error message either. But I have to say it could
be the best terminal plugin in atom-windows


Reply to this email directly or view it on GitHub
#15.

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 19, 2015

It's still not working.

zaaack commented Sep 19, 2015

It's still not working.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 19, 2015

Owner

I'll have to take a look and run some tests of my own. I'll notify you here if I need any more information, or if I publish a release that fixes this issue.

Owner

jeremyramin commented Sep 19, 2015

I'll have to take a look and run some tests of my own. I'll notify you here if I need any more information, or if I publish a release that fixes this issue.

@jeremyramin jeremyramin added the bug label Sep 19, 2015

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 19, 2015

I'll really appreciate it.

zaaack commented Sep 19, 2015

I'll really appreciate it.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 21, 2015

Owner

I know what the issue is now. I should have a fix for it soon.

Owner

jeremyramin commented Sep 21, 2015

I know what the issue is now. I should have a fix for it soon.

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 21, 2015

congratulations!!It's fast.

zaaack commented Sep 21, 2015

congratulations!!It's fast.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 22, 2015

Owner

Please update to the latest version of Atom (1.0.15) and try to use the package.

Owner

jeremyramin commented Sep 22, 2015

Please update to the latest version of Atom (1.0.15) and try to use the package.

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 22, 2015

Thanks, I'll try in few fours.

zaaack commented Sep 22, 2015

Thanks, I'll try in few fours.

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 22, 2015

I'm sorry to say that it still looks not working...
qq 20150922154252

zaaack commented Sep 22, 2015

I'm sorry to say that it still looks not working...
qq 20150922154252

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 22, 2015

Owner

Can you please show me what your console says?

Owner

jeremyramin commented Sep 22, 2015

Can you please show me what your console says?

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 22, 2015

There are still nothing
qq 20150922154252

zaaack commented Sep 22, 2015

There are still nothing
qq 20150922154252

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 22, 2015

image
And I can find the winpty process in my tasklist

zaaack commented Sep 22, 2015

image
And I can find the winpty process in my tasklist

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 22, 2015

Owner

That means it was launched but it didn't work, which is different from what I originally thought was wrong. I'm surprised that you aren't seeing any error output. This is an issue with a dependency of the package, which I'll have to look at and get back to you.

Owner

jeremyramin commented Sep 22, 2015

That means it was launched but it didn't work, which is different from what I originally thought was wrong. I'm surprised that you aren't seeing any error output. This is an issue with a dependency of the package, which I'll have to look at and get back to you.

@Maistho

This comment has been minimized.

Show comment
Hide comment
@Maistho

Maistho Sep 24, 2015

I seem to have a similar issue, but I also get a message in the console every time I try to open the terminal.

Cannot find module '../build/Release/pty.node' 
C:\Users\maistho\AppData\Local\atom\app-1.0.16\resources\app.asar\src\task.js:47

I'm running Windows 10, Atom 1.0.16, Terminal Plus 0.5.1

Please let me know if there's anything I can do to help debug this. =)

Maistho commented Sep 24, 2015

I seem to have a similar issue, but I also get a message in the console every time I try to open the terminal.

Cannot find module '../build/Release/pty.node' 
C:\Users\maistho\AppData\Local\atom\app-1.0.16\resources\app.asar\src\task.js:47

I'm running Windows 10, Atom 1.0.16, Terminal Plus 0.5.1

Please let me know if there's anything I can do to help debug this. =)

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 24, 2015

Owner

@Maistho This is because you don't have the tools necessary to compile the native module dependencies of Terminal-Plus (see author's note in README). However, the plugin will still work because I provide precompiled binaries for each operating system.

Owner

jeremyramin commented Sep 24, 2015

@Maistho This is because you don't have the tools necessary to compile the native module dependencies of Terminal-Plus (see author's note in README). However, the plugin will still work because I provide precompiled binaries for each operating system.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 24, 2015

Owner

@Maistho Actually, which language are you using on your system?

Owner

jeremyramin commented Sep 24, 2015

@Maistho Actually, which language are you using on your system?

@thers

This comment has been minimized.

Show comment
Hide comment
@thers

thers Sep 24, 2015

Same problem. Have properly installed node-gyp and devtools console still reports that pty.node module cannot be found.

thers commented Sep 24, 2015

Same problem. Have properly installed node-gyp and devtools console still reports that pty.node module cannot be found.

@Maistho

This comment has been minimized.

Show comment
Hide comment
@Maistho

Maistho Sep 24, 2015

@jeremyramin I'm using English UK, but I'm in Sweden and have Swedish time and currency format. Does language affect what binaries are used?

It seems that the winpty process starts (I can see it in taskmgr) but the terminal never loads. (Just a blinking cursor)

Maistho commented Sep 24, 2015

@jeremyramin I'm using English UK, but I'm in Sweden and have Swedish time and currency format. Does language affect what binaries are used?

It seems that the winpty process starts (I can see it in taskmgr) but the terminal never loads. (Just a blinking cursor)

@Maistho

This comment has been minimized.

Show comment
Hide comment
@Maistho

Maistho Sep 24, 2015

I updated to 0.6.0, still have the same issue.
What do I need to install in order to compile the native module dependencies? (I already have nodejs and node-gyp installed globally)

Maistho commented Sep 24, 2015

I updated to 0.6.0, still have the same issue.
What do I need to install in order to compile the native module dependencies? (I already have nodejs and node-gyp installed globally)

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 24, 2015

Owner

@RiderSx There still might be an error causing node-gyp not to compile the binaries properly. The way to check this is to navigate to the pty.js dependency folder for Terminal-Plus and look at the builderror.log file.
Win: C:\Users\{your username}\.atom\packages\terminal-plus\node_modules\pty.js\builderror.log
Mac: /Users/{your username}/.atom/packages/terminal-plus/node_modules/pty.js/builderror.log

@Maistho I'm starting to think that this might be an issue with the pty.js dependency having a conflict with systems using a different language. I'll have to look through their code and see why this would even be an issue. Also, these are the node-gyp install instructions for every platform. You need a couple more things for compiling binaries.

Owner

jeremyramin commented Sep 24, 2015

@RiderSx There still might be an error causing node-gyp not to compile the binaries properly. The way to check this is to navigate to the pty.js dependency folder for Terminal-Plus and look at the builderror.log file.
Win: C:\Users\{your username}\.atom\packages\terminal-plus\node_modules\pty.js\builderror.log
Mac: /Users/{your username}/.atom/packages/terminal-plus/node_modules/pty.js/builderror.log

@Maistho I'm starting to think that this might be an issue with the pty.js dependency having a conflict with systems using a different language. I'll have to look through their code and see why this would even be an issue. Also, these are the node-gyp install instructions for every platform. You need a couple more things for compiling binaries.

@Maistho

This comment has been minimized.

Show comment
Hide comment
@Maistho

Maistho Sep 24, 2015

What language would it work on? I could test changing my system language or locale and see if that solves it.

Thanks for the link! =)

Maistho commented Sep 24, 2015

What language would it work on? I could test changing my system language or locale and see if that solves it.

Thanks for the link! =)

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 24, 2015

Owner

I'm assuming that English is the only language it works on right now. If you could, please try changing the time and currency to English (or English UK in your case). If that still doesn't work, then we need to make sure that there aren't any other settings affecting the language on your system.

Owner

jeremyramin commented Sep 24, 2015

I'm assuming that English is the only language it works on right now. If you could, please try changing the time and currency to English (or English UK in your case). If that still doesn't work, then we need to make sure that there aren't any other settings affecting the language on your system.

@Maistho

This comment has been minimized.

Show comment
Hide comment
@Maistho

Maistho Sep 24, 2015

Still doesn't seem to work (with english/UK). I'll try installing python and the other things needed for node-gyp and then rebuild, see if that helps.

Maistho commented Sep 24, 2015

Still doesn't seem to work (with english/UK). I'll try installing python and the other things needed for node-gyp and then rebuild, see if that helps.

@Maistho

This comment has been minimized.

Show comment
Hide comment
@Maistho

Maistho Sep 24, 2015

Also, I'm not sure if this is related, but if I try to uninstall while winpty-agent.exe is running the uninstall fails silently. I have to manually close the process in taskmgr before I can uninstall Terminal-plus

Maistho commented Sep 24, 2015

Also, I'm not sure if this is related, but if I try to uninstall while winpty-agent.exe is running the uninstall fails silently. I have to manually close the process in taskmgr before I can uninstall Terminal-plus

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 24, 2015

but if I try to uninstall while winpty-agent.exe is running the uninstall fails silently. I have to manually close the process in taskmgr before I can uninstall Terminal-plus

I have same problem, winpty-agent.exe process won't be killed after close the terminal tab.

zaaack commented Sep 24, 2015

but if I try to uninstall while winpty-agent.exe is running the uninstall fails silently. I have to manually close the process in taskmgr before I can uninstall Terminal-plus

I have same problem, winpty-agent.exe process won't be killed after close the terminal tab.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 25, 2015

Owner

This could be a problem with the winpty-agent. I'll find some time in the next couple days to go through the code. Winpty is a dependency of a Terminal-Plus dependency, so I haven't dealt with it much.

Owner

jeremyramin commented Sep 25, 2015

This could be a problem with the winpty-agent. I'll find some time in the next couple days to go through the code. Winpty is a dependency of a Terminal-Plus dependency, so I haven't dealt with it much.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 26, 2015

Owner

@Maistho I'm curious. Did installing the proper tools for node-gyp and compiling your own version fix this issue for you?

Owner

jeremyramin commented Sep 26, 2015

@Maistho I'm curious. Did installing the proper tools for node-gyp and compiling your own version fix this issue for you?

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 26, 2015

@jeremyramin I installed the vs2012 for desktop, I can find the winpty-agent.exe file in build directory, but there are no pty.node file, so the console shows can't find "../build/pty.node", I tried copy pty.node from bin/ to build/, but It's useless...

zaaack commented Sep 26, 2015

@jeremyramin I installed the vs2012 for desktop, I can find the winpty-agent.exe file in build directory, but there are no pty.node file, so the console shows can't find "../build/pty.node", I tried copy pty.node from bin/ to build/, but It's useless...

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Sep 26, 2015

Owner

@yzhen123 Use the following command to rebuild the pty.js dependency from the pty.js folder:
node-gyp rebuild --target=0.30.6 --dist-url=https://atom.io/download/atom-shell

Owner

jeremyramin commented Sep 26, 2015

@yzhen123 Use the following command to rebuild the pty.js dependency from the pty.js folder:
node-gyp rebuild --target=0.30.6 --dist-url=https://atom.io/download/atom-shell

@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Sep 26, 2015

I tried several times but failed because of the poor network or some other reason, I'll keep trying tomorrow.

zaaack commented Sep 26, 2015

I tried several times but failed because of the poor network or some other reason, I'll keep trying tomorrow.

@T1mClark

This comment has been minimized.

Show comment
Hide comment
@T1mClark

T1mClark Oct 1, 2015

This is not a Terminal-Plus issue. Microsoft has changed the console code in Windows 10 and it breaks current shells on most editors. The work-a-round is:

  1. Bring up a command prompt.
  2. Click on the Settings icon (Top left corner)
  3. Select Properties > Options > Check "Use legacy console"
  4. Close and re-open ATOM or any other editor and test.

T1mClark commented Oct 1, 2015

This is not a Terminal-Plus issue. Microsoft has changed the console code in Windows 10 and it breaks current shells on most editors. The work-a-round is:

  1. Bring up a command prompt.
  2. Click on the Settings icon (Top left corner)
  3. Select Properties > Options > Check "Use legacy console"
  4. Close and re-open ATOM or any other editor and test.
@zaaack

This comment has been minimized.

Show comment
Hide comment
@zaaack

zaaack Oct 1, 2015

@T1mClark Thanks!!! it works for me.

zaaack commented Oct 1, 2015

@T1mClark Thanks!!! it works for me.

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Oct 1, 2015

Owner

@T1mClark Thank you! I've been trying to figure this out for days now. I'll have to put this on the README somewhere.

Owner

jeremyramin commented Oct 1, 2015

@T1mClark Thank you! I've been trying to figure this out for days now. I'll have to put this on the README somewhere.

@T1mClark

This comment has been minimized.

Show comment
Hide comment
@T1mClark

T1mClark Oct 1, 2015

No Problem. Thank you for the excellent plugin.

T1mClark commented Oct 1, 2015

No Problem. Thank you for the excellent plugin.

@zaaack zaaack closed this Oct 2, 2015

@mickdekkers

This comment has been minimized.

Show comment
Hide comment
@mickdekkers

mickdekkers Oct 5, 2015

@jeremyramin you may wanna put this in the author's notes :P

@jeremyramin you may wanna put this in the author's notes :P

@jeremyramin

This comment has been minimized.

Show comment
Hide comment
@jeremyramin

jeremyramin Oct 5, 2015

Owner

@soullesswaffle You're right, sorry about that. Just added it :)

Owner

jeremyramin commented Oct 5, 2015

@soullesswaffle You're right, sorry about that. Just added it :)

@lateau

This comment has been minimized.

Show comment
Hide comment
@lateau

lateau Nov 22, 2015

I found kaspersky blocks winpty-agent.exe. I just added a new rule to allows winpty-agent.exe then works perfectly.

lateau commented Nov 22, 2015

I found kaspersky blocks winpty-agent.exe. I just added a new rule to allows winpty-agent.exe then works perfectly.

@flyysoul

This comment has been minimized.

Show comment
Hide comment
@flyysoul

flyysoul Mar 29, 2016

@T1mClark @jeremyramin
I'm running Win10, Atom 1.2.4, Terminal Plus 0.14.5,I choose "Use legacy console" in a command prompt and close,re-open Atom ,but its not work for me (;′⌒)


Today the plus is ok Suddenly.I don`t know what happend……(⊙o⊙)…

@T1mClark @jeremyramin
I'm running Win10, Atom 1.2.4, Terminal Plus 0.14.5,I choose "Use legacy console" in a command prompt and close,re-open Atom ,but its not work for me (;′⌒)


Today the plus is ok Suddenly.I don`t know what happend……(⊙o⊙)…

@mkg0 mkg0 referenced this issue May 10, 2016

Open

Not working #253

@nmdanny

This comment has been minimized.

Show comment
Hide comment
@nmdanny

nmdanny May 13, 2016

I'm on windows 10 insider builder 14342 and I also face a similar issue. platformio-ide-terminal seems to work better, although it is buggy when deleting chars from input, not sure if it's related to this bug.

nmdanny commented May 13, 2016

I'm on windows 10 insider builder 14342 and I also face a similar issue. platformio-ide-terminal seems to work better, although it is buggy when deleting chars from input, not sure if it's related to this bug.

@divmonkey

This comment has been minimized.

Show comment
Hide comment
@divmonkey

divmonkey Jun 15, 2016

Win 10 x64 also with Atom 1.8.0 and I load up terminal plus, its just empty. I followed that guide above "Use legacy console", still didn't work. Any idea? And oh, I already have Nodejs and Git bash.

Win 10 x64 also with Atom 1.8.0 and I load up terminal plus, its just empty. I followed that guide above "Use legacy console", still didn't work. Any idea? And oh, I already have Nodejs and Git bash.

@ivankravets

This comment has been minimized.

Show comment
Hide comment

@divmonkey have you tried this #15 (comment) ?

@divmonkey

This comment has been minimized.

Show comment
Hide comment
@divmonkey

divmonkey Jun 16, 2016

@ivankravets Thank you. That works! however it uses the powershell but it'll do :)

@ivankravets Thank you. That works! however it uses the powershell but it'll do :)

@gikey

This comment has been minimized.

Show comment
Hide comment
@gikey

gikey Aug 27, 2016

I found terminal-plus can not work again。atom v1.9.9

gikey commented Aug 27, 2016

I found terminal-plus can not work again。atom v1.9.9

@talkahe talkahe referenced this issue in HiFaraz/node-playbook Aug 30, 2016

Closed

Terminal-plus package for Atom is inactive. #23

@kiwio

This comment has been minimized.

Show comment
Hide comment
@kiwio

kiwio Sep 5, 2016

I just installed Atom with terminal-plus on top of it and I can't seem to type anything inside. The versions are 1.10.0 and 0.14.5 respectively. I'm on Windows 10 (10586.545 build).

kiwio commented Sep 5, 2016

I just installed Atom with terminal-plus on top of it and I can't seem to type anything inside. The versions are 1.10.0 and 0.14.5 respectively. I'm on Windows 10 (10586.545 build).

@shenshouer

This comment has been minimized.

Show comment
Hide comment
@shenshouer

shenshouer Sep 6, 2016

the same issue for atom 1.10.1 and 0.14.5 on mac osx 10.11.6

the same issue for atom 1.10.1 and 0.14.5 on mac osx 10.11.6

@swapnilchincholkar

This comment has been minimized.

Show comment
Hide comment
@swapnilchincholkar

swapnilchincholkar Sep 8, 2016

Same issue atom 1.10.2, 0.14.5 on mac 10.9.5

Same issue atom 1.10.2, 0.14.5 on mac 10.9.5

@andrezap

This comment has been minimized.

Show comment
Hide comment
@andrezap

andrezap Sep 11, 2016

same issue for atom 1.10.1 on win10

same issue for atom 1.10.1 on win10

@shahmir811

This comment has been minimized.

Show comment
Hide comment
@shahmir811

shahmir811 Sep 12, 2016

same issue for atom 1.10.2 on win7

same issue for atom 1.10.2 on win7

@turshija

This comment has been minimized.

Show comment
Hide comment
@turshija

turshija Sep 13, 2016

I'm having same issue but on MacOS, Atom 1.10.2
When I open terminal, I see only black background with blinking cursor like this: http://www.pics.rs/i/31Nld
My .atom/packages/terminal-plus/node_modules/pty.js/builderror.log shows this:

In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:27:
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/src/node_object_wrap.h:64:18: warning: 'SetWeak<node::ObjectWrap>' is deprecated [-Wdeprecated-declarations]
    persistent().SetWeak(this, WeakCallback);
                 ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:561:12: note: 'SetWeak<node::ObjectWrap>' has been explicitly marked deprecated here
      void SetWeak(P* parameter,
           ^
In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:184:
../../nan/nan_maybe_43_inl.h:89:15: warning: 'ForceSet' is deprecated [-Wdeprecated-declarations]
  return obj->ForceSet(GetCurrentContext(), key, value, attribs);
              ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:2682:29: note: 'ForceSet' has been explicitly marked deprecated here
                Maybe<bool> ForceSet(Local<Context> context, Local<Value> key,
                            ^
In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:184:
../../nan/nan_maybe_43_inl.h:221:17: warning: 'CloneElementAt' is deprecated [-Wdeprecated-declarations]
  return array->CloneElementAt(GetCurrentContext(), index);
                ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:3011:36: note: 'CloneElementAt' has been explicitly marked deprecated here
                MaybeLocal<Object> CloneElementAt(Local<Context> context,
                                   ^
In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:190:
In file included from ../../nan/nan_new.h:189:
../../nan/nan_implementation_12_inl.h:40:29: warning: 'New' is deprecated [-Wdeprecated-declarations]
  return v8::BooleanObject::New(value).As<v8::BooleanObject>();
                            ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:3972:56: note: 'New' has been explicitly marked deprecated here
  V8_DEPRECATED("Pass an isolate", static Local<Value> New(bool value));
                                                       ^
In file included from ../src/unix/pty.cc:20:
../../nan/nan.h:592:20: error: no type named 'GCEpilogueCallback' in 'v8::Isolate'
      v8::Isolate::GCEpilogueCallback callback
      ~~~~~~~~~~~~~^
../../nan/nan.h:598:20: error: no type named 'GCEpilogueCallback' in 'v8::Isolate'
      v8::Isolate::GCEpilogueCallback callback) {
      ~~~~~~~~~~~~~^
../../nan/nan.h:603:20: error: no type named 'GCPrologueCallback' in 'v8::Isolate'
      v8::Isolate::GCPrologueCallback callback
      ~~~~~~~~~~~~~^
../../nan/nan.h:609:20: error: no type named 'GCPrologueCallback' in 'v8::Isolate'
      v8::Isolate::GCPrologueCallback callback) {
      ~~~~~~~~~~~~~^
../../nan/nan.h:1933:15: warning: 'SetAccessor' is deprecated [-Wdeprecated-declarations]
  return obj->SetAccessor(
              ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:2735:22: note: 'SetAccessor' has been explicitly marked deprecated here
                bool SetAccessor(Local<Name> name,
                     ^
5 warnings and 4 errors generated.
make: *** [Release/obj.target/pty/src/unix/pty.o] Error 1
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
gyp ERR! System Darwin 15.6.0
gyp ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/.bin/node-gyp" "rebuild"
gyp ERR! cwd /private/var/folders/tw/dy1r430n3jd2dqp52w9kpff40000gn/T/apm-install-dir-116813-81670-1asu70i/node_modules/terminal-plus/node_modules/pty.js
gyp ERR! node -v v4.4.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok 

I'm having same issue but on MacOS, Atom 1.10.2
When I open terminal, I see only black background with blinking cursor like this: http://www.pics.rs/i/31Nld
My .atom/packages/terminal-plus/node_modules/pty.js/builderror.log shows this:

In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:27:
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/src/node_object_wrap.h:64:18: warning: 'SetWeak<node::ObjectWrap>' is deprecated [-Wdeprecated-declarations]
    persistent().SetWeak(this, WeakCallback);
                 ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:561:12: note: 'SetWeak<node::ObjectWrap>' has been explicitly marked deprecated here
      void SetWeak(P* parameter,
           ^
In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:184:
../../nan/nan_maybe_43_inl.h:89:15: warning: 'ForceSet' is deprecated [-Wdeprecated-declarations]
  return obj->ForceSet(GetCurrentContext(), key, value, attribs);
              ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:2682:29: note: 'ForceSet' has been explicitly marked deprecated here
                Maybe<bool> ForceSet(Local<Context> context, Local<Value> key,
                            ^
In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:184:
../../nan/nan_maybe_43_inl.h:221:17: warning: 'CloneElementAt' is deprecated [-Wdeprecated-declarations]
  return array->CloneElementAt(GetCurrentContext(), index);
                ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:3011:36: note: 'CloneElementAt' has been explicitly marked deprecated here
                MaybeLocal<Object> CloneElementAt(Local<Context> context,
                                   ^
In file included from ../src/unix/pty.cc:20:
In file included from ../../nan/nan.h:190:
In file included from ../../nan/nan_new.h:189:
../../nan/nan_implementation_12_inl.h:40:29: warning: 'New' is deprecated [-Wdeprecated-declarations]
  return v8::BooleanObject::New(value).As<v8::BooleanObject>();
                            ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:3972:56: note: 'New' has been explicitly marked deprecated here
  V8_DEPRECATED("Pass an isolate", static Local<Value> New(bool value));
                                                       ^
In file included from ../src/unix/pty.cc:20:
../../nan/nan.h:592:20: error: no type named 'GCEpilogueCallback' in 'v8::Isolate'
      v8::Isolate::GCEpilogueCallback callback
      ~~~~~~~~~~~~~^
../../nan/nan.h:598:20: error: no type named 'GCEpilogueCallback' in 'v8::Isolate'
      v8::Isolate::GCEpilogueCallback callback) {
      ~~~~~~~~~~~~~^
../../nan/nan.h:603:20: error: no type named 'GCPrologueCallback' in 'v8::Isolate'
      v8::Isolate::GCPrologueCallback callback
      ~~~~~~~~~~~~~^
../../nan/nan.h:609:20: error: no type named 'GCPrologueCallback' in 'v8::Isolate'
      v8::Isolate::GCPrologueCallback callback) {
      ~~~~~~~~~~~~~^
../../nan/nan.h:1933:15: warning: 'SetAccessor' is deprecated [-Wdeprecated-declarations]
  return obj->SetAccessor(
              ^
/Users/{my user}/.atom/.node-gyp/.node-gyp/0.37.8/deps/v8/include/v8.h:2735:22: note: 'SetAccessor' has been explicitly marked deprecated here
                bool SetAccessor(Local<Name> name,
                     ^
5 warnings and 4 errors generated.
make: *** [Release/obj.target/pty/src/unix/pty.o] Error 1
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/node-gyp/lib/build.js:276:23)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
gyp ERR! System Darwin 15.6.0
gyp ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/.bin/node-gyp" "rebuild"
gyp ERR! cwd /private/var/folders/tw/dy1r430n3jd2dqp52w9kpff40000gn/T/apm-install-dir-116813-81670-1asu70i/node_modules/terminal-plus/node_modules/pty.js
gyp ERR! node -v v4.4.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok 
@swapnilchincholkar

This comment has been minimized.

Show comment
Hide comment
@swapnilchincholkar

swapnilchincholkar Sep 14, 2016

Solution at 321 worked for me for mac.

Solution at 321 worked for me for mac.

@NatashaKSS

This comment has been minimized.

Show comment
Hide comment
@NatashaKSS

NatashaKSS Sep 15, 2016

Previously tried on Atom 1.9.9, Win 10, same issue.
I have since migrated over to platformio-ide-terminal

NatashaKSS commented Sep 15, 2016

Previously tried on Atom 1.9.9, Win 10, same issue.
I have since migrated over to platformio-ide-terminal

@phillip-haydon

This comment has been minimized.

Show comment
Hide comment
@phillip-haydon

phillip-haydon Sep 24, 2016

Thanks @NatashaKSS - works perfectly.

Thanks @NatashaKSS - works perfectly.

@Zeklandia

This comment has been minimized.

Show comment
Hide comment
@Zeklandia

Zeklandia Sep 28, 2016

Atom 1.10.2, Windows 10 Pro, 64-bit, build 1607, 14388.0

Here's the error I get:

Module version mismatch. Expected 47, got 46. Error: Module version mismatch. Expected 47, got 46.
    at Error (native)
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:158:20)
    at Object.Module._extensions..node (module.js:440:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:158:20)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\Users\Zeklandia\.atom\packages\terminal-plus\node_modules\pty.js\lib\pty.js:17:9)
    at Module._compile (module.js:413:34)
    at Object.defineProperty.value [as .js] (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\Users\Zeklandia\.atom\packages\terminal-plus\node_modules\pty.js\lib\pty_win.js:10:20)
    at Module._compile (module.js:413:34)
    at Object.defineProperty.value [as .js] (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\Users\Zeklandia\.atom\packages\terminal-plus\node_modules\pty.js\index.js:2:18)
    at Module._compile (module.js:413:34)
    at Object.defineProperty.value [as .js] (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous>
(file:///C:/Users/Zeklandia/.atom/packages/terminal-plus/lib/process.coffee:1:7)(anonymous function) @ C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52
4C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52 Cannot read property 'bind' of null TypeError: Cannot read property 'bind' of null
    at process.<anonymous> (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task-bootstrap.js:82:23)
    at emitTwo (events.js:100:13)
    at process.emit (events.js:185:7)
    at handleMessage (internal/child_process.js:718:10)
    at Pipe.channel.onread (internal/child_process.js:444:11)(anonymous function) @ C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52

followed by:

C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52 Cannot read property 'bind' of null TypeError: Cannot read property 'bind' of null
    at process.<anonymous> (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task-bootstrap.js:82:23)
    at emitTwo (events.js:100:13)
    at process.emit (events.js:185:7)
    at handleMessage (internal/child_process.js:718:10)
    at Pipe.channel.onread (internal/child_process.js:444:11)(anonymous function) @ C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52
C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:49 Cannot find module '../build/Release/pty.node'

Atom 1.10.2, Windows 10 Pro, 64-bit, build 1607, 14388.0

Here's the error I get:

Module version mismatch. Expected 47, got 46. Error: Module version mismatch. Expected 47, got 46.
    at Error (native)
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:158:20)
    at Object.Module._extensions..node (module.js:440:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:158:20)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\Users\Zeklandia\.atom\packages\terminal-plus\node_modules\pty.js\lib\pty.js:17:9)
    at Module._compile (module.js:413:34)
    at Object.defineProperty.value [as .js] (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\Users\Zeklandia\.atom\packages\terminal-plus\node_modules\pty.js\lib\pty_win.js:10:20)
    at Module._compile (module.js:413:34)
    at Object.defineProperty.value [as .js] (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous> (C:\Users\Zeklandia\.atom\packages\terminal-plus\node_modules\pty.js\index.js:2:18)
    at Module._compile (module.js:413:34)
    at Object.defineProperty.value [as .js] (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\compile-cache.js:208:21)
    at Module.load (module.js:357:32)
    at Function.Module._load (module.js:314:12)
    at Module.require (module.js:367:17)
    at require (internal/module.js:16:19)
    at Object.<anonymous>
(file:///C:/Users/Zeklandia/.atom/packages/terminal-plus/lib/process.coffee:1:7)(anonymous function) @ C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52
4C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52 Cannot read property 'bind' of null TypeError: Cannot read property 'bind' of null
    at process.<anonymous> (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task-bootstrap.js:82:23)
    at emitTwo (events.js:100:13)
    at process.emit (events.js:185:7)
    at handleMessage (internal/child_process.js:718:10)
    at Pipe.channel.onread (internal/child_process.js:444:11)(anonymous function) @ C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52

followed by:

C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52 Cannot read property 'bind' of null TypeError: Cannot read property 'bind' of null
    at process.<anonymous> (C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task-bootstrap.js:82:23)
    at emitTwo (events.js:100:13)
    at process.emit (events.js:185:7)
    at handleMessage (internal/child_process.js:718:10)
    at Pipe.channel.onread (internal/child_process.js:444:11)(anonymous function) @ C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:52
C:\Users\Zeklandia\AppData\Local\atom\app-1.10.2\resources\app.asar\src\task.js:49 Cannot find module '../build/Release/pty.node'
@wowzaaa

This comment has been minimized.

Show comment
Hide comment
@wowzaaa

wowzaaa Sep 29, 2016

same as @Zeklandia :(
installed plateformio-ide-terminal ... works perfectly

wowzaaa commented Sep 29, 2016

same as @Zeklandia :(
installed plateformio-ide-terminal ... works perfectly

@Zeklandia

This comment has been minimized.

Show comment
Hide comment
@Zeklandia

Zeklandia Sep 30, 2016

Same here, @wowzaaa! platformio-ide-terminal works fine.

Same here, @wowzaaa! platformio-ide-terminal works fine.

@konekoya

This comment has been minimized.

Show comment
Hide comment
@konekoya

konekoya Oct 14, 2016

Not sure if it's appropriate to ask here?
platformio-ide-terminal works great on my windows 10. But I've run into another problem. I tried to change the default shell to git-bash but after launching the terminal it just opens the git bash not opening it inside Atom pane.

konekoya commented Oct 14, 2016

Not sure if it's appropriate to ask here?
platformio-ide-terminal works great on my windows 10. But I've run into another problem. I tried to change the default shell to git-bash but after launching the terminal it just opens the git bash not opening it inside Atom pane.

@EnlightonOcean

This comment has been minimized.

Show comment
Hide comment
@EnlightonOcean

EnlightonOcean Oct 15, 2016

can some one please help me resolve this issue
error

can some one please help me resolve this issue
error

@EnlightonOcean

This comment has been minimized.

Show comment
Hide comment
@EnlightonOcean

EnlightonOcean Oct 15, 2016

Cannot find python executables. Please help

Cannot find python executables. Please help

@EnlightonOcean

This comment has been minimized.

Show comment
Hide comment
@EnlightonOcean

EnlightonOcean Oct 15, 2016

Getting error while running node-gyp rebuild --target=0.30.6 --dist-url=https://atom.io/download/atom-shell

Getting error while running node-gyp rebuild --target=0.30.6 --dist-url=https://atom.io/download/atom-shell

@EnlightonOcean

This comment has been minimized.

Show comment
Hide comment
@EnlightonOcean

EnlightonOcean Oct 16, 2016

Running command C:\Users\mailt.atom\packages\terminal-plus\node_modules\pty.js> node-gyp rebuild --target=0.30.6 --dist-url=https://atom.io/download/atom-shell
is giving following error

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error
MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK vers
ion in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\Users\mailt
.atom\packages\terminal-plus\node_modules\pty.js\build\deps\winpty\winpty-agent.vcxproj]
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error
MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK vers
ion in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\Users\mailt
C:\Users\mailt.atom\packages\terminal-plus\node_modules\pty.js\build\deps\winpty\winpty.vcxproj]

Running command C:\Users\mailt.atom\packages\terminal-plus\node_modules\pty.js> node-gyp rebuild --target=0.30.6 --dist-url=https://atom.io/download/atom-shell
is giving following error

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error
MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK vers
ion in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\Users\mailt
.atom\packages\terminal-plus\node_modules\pty.js\build\deps\winpty\winpty-agent.vcxproj]
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\v140\Toolset.targets(36,5): error
MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK vers
ion in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\Users\mailt
C:\Users\mailt.atom\packages\terminal-plus\node_modules\pty.js\build\deps\winpty\winpty.vcxproj]

@guibot17

This comment has been minimized.

Show comment
Hide comment
@guibot17

guibot17 Oct 25, 2016

I'm having the same issue with terminal-plus 0.14.5 on Win 10, x64.

events.js:154
Hide Stack Trace
Error: channel closed
at ChildProcess.target.send (internal/child_process.js:523:16)
at Task.module.exports.Task.send (C:\Users\name\AppData\Local\atom\app-1.11.2\resources\app.asar\src\task.js:117:27)
at TerminalPlusView.module.exports.TerminalPlusView.input (file:///C:/Users/name/.atom/packages/terminal-plus/lib/view.coffee:261:17)
at Terminal. (file:///C:/Users/name/.atom/packages/terminal-plus/lib/view.coffee:141:8)
at Terminal.EventEmitter.emit (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.js:109:12)
at Terminal.handler (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.js:3493:8)
at Terminal.keyPress (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.js:3243:8)
at HTMLDocument. (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.

I've tried every possible solution given here with no success.
Any help will be appreciated.

I'm having the same issue with terminal-plus 0.14.5 on Win 10, x64.

events.js:154
Hide Stack Trace
Error: channel closed
at ChildProcess.target.send (internal/child_process.js:523:16)
at Task.module.exports.Task.send (C:\Users\name\AppData\Local\atom\app-1.11.2\resources\app.asar\src\task.js:117:27)
at TerminalPlusView.module.exports.TerminalPlusView.input (file:///C:/Users/name/.atom/packages/terminal-plus/lib/view.coffee:261:17)
at Terminal. (file:///C:/Users/name/.atom/packages/terminal-plus/lib/view.coffee:141:8)
at Terminal.EventEmitter.emit (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.js:109:12)
at Terminal.handler (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.js:3493:8)
at Terminal.keyPress (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.js:3243:8)
at HTMLDocument. (C:\Users\name.atom\packages\terminal-plus\node_modules\term.js\src\term.

I've tried every possible solution given here with no success.
Any help will be appreciated.

@jeff-wu

This comment has been minimized.

Show comment
Hide comment
@jeff-wu

jeff-wu Nov 1, 2016

same issue with terminal-plus 0.14.5 on Win 10, x64 atom 1.11.2

jeff-wu commented Nov 1, 2016

same issue with terminal-plus 0.14.5 on Win 10, x64 atom 1.11.2

@Aisuko

This comment has been minimized.

Show comment
Hide comment
@Aisuko

Aisuko Nov 2, 2016

Did it work? @jeff-wu The same issue with you

Aisuko commented Nov 2, 2016

Did it work? @jeff-wu The same issue with you

@Dagrut

This comment has been minimized.

Show comment
Hide comment
@Dagrut

Dagrut Nov 14, 2016

Same issue here, same bug happened (on a fresh install of atom on a debian stable that was just upgraded this morning).
And plateformio-ide-terminal works perfectly.

Dagrut commented Nov 14, 2016

Same issue here, same bug happened (on a fresh install of atom on a debian stable that was just upgraded this morning).
And plateformio-ide-terminal works perfectly.

@guibot17

This comment has been minimized.

Show comment
Hide comment
@guibot17

guibot17 Nov 20, 2016

plateformio-ide-terminal doesn't work for me neither. I have a on Win 10, x64.

plateformio-ide-terminal doesn't work for me neither. I have a on Win 10, x64.

@jarig

This comment has been minimized.

Show comment
Hide comment
@jarig

jarig Nov 29, 2016

Doesn't work here as well with the latest stable Atom 1.12.6

jarig commented Nov 29, 2016

Doesn't work here as well with the latest stable Atom 1.12.6

@nrvarun

This comment has been minimized.

Show comment
Hide comment
@nrvarun

nrvarun Dec 4, 2016

platformio-ide-terminalis working but not terminal plus. I have a windows 10, x64.

nrvarun commented Dec 4, 2016

platformio-ide-terminalis working but not terminal plus. I have a windows 10, x64.

@dehghani-mehdi

This comment has been minimized.

Show comment
Hide comment
@dehghani-mehdi

dehghani-mehdi Dec 6, 2016

Doesn't work here too, I just installed Atom & terminal-plus. (windows 10 x64)
(I tired this, but the terminal open seems like it's disable)

Doesn't work here too, I just installed Atom & terminal-plus. (windows 10 x64)
(I tired this, but the terminal open seems like it's disable)

@smolinari

This comment has been minimized.

Show comment
Hide comment
@smolinari

smolinari Dec 28, 2016

I too can't get terminal-plus to work with Windows 10. I am stuck at pty.js not building and failing with

Call to 'node -e "require('nan')"' returned exit status -1073741819 while in binding.gyp. while trying to load binding.gyp

I've tried everything mentioned here.

Edit: I've installed platformio-ide-terminal and it seems to be working.

Scott

smolinari commented Dec 28, 2016

I too can't get terminal-plus to work with Windows 10. I am stuck at pty.js not building and failing with

Call to 'node -e "require('nan')"' returned exit status -1073741819 while in binding.gyp. while trying to load binding.gyp

I've tried everything mentioned here.

Edit: I've installed platformio-ide-terminal and it seems to be working.

Scott

@smowrey

This comment has been minimized.

Show comment
Hide comment
@smowrey

smowrey Apr 9, 2017

I've too installed platformer-ide-terminal and it worked immediately. Thanks @smolinari

smowrey commented Apr 9, 2017

I've too installed platformer-ide-terminal and it worked immediately. Thanks @smolinari

@jay23794

This comment has been minimized.

Show comment
Hide comment
@jay23794

jay23794 Oct 3, 2017

Installing “terminal-plus@0.14.5” failed.Hide output…
Failed to install terminal-plus because Git was not found.
The terminal-plus package has module dependencies that cannot be installed without Git.
You need to install Git and add it to your path environment variable in order to install this package.
You can install Git by downloading, installing, and launching GitHub for Windows: https://windows.github.com
Run apm -v after installing Git to see what version has
showing this kind of error what to do

jay23794 commented Oct 3, 2017

Installing “terminal-plus@0.14.5” failed.Hide output…
Failed to install terminal-plus because Git was not found.
The terminal-plus package has module dependencies that cannot be installed without Git.
You need to install Git and add it to your path environment variable in order to install this package.
You can install Git by downloading, installing, and launching GitHub for Windows: https://windows.github.com
Run apm -v after installing Git to see what version has
showing this kind of error what to do

@P403n1x87 P403n1x87 referenced this issue in platformio/platformio-atom-ide-terminal Nov 1, 2017

Open

Deleting characters is buggy in git-bash on Windows 10 #108

@abhishekhandacse

This comment has been minimized.

Show comment
Hide comment
@abhishekhandacse

abhishekhandacse Nov 6, 2017

Processing -File 'E:\CompSci\Project X\Project-X\templates\basic_app\registration.html' failed because the file does not have a '.ps1' extension. Specify a val
id Windows PowerShell script file name, and then try again.
Windows PowerShell
Copyright (C) 2016 Microsoft Corporation. All rights reserved.

Processing -File 'E:\CompSci\Project X\Project-X\templates\basic_app\registration.html' failed because the file does not have a '.ps1' extension. Specify a val
id Windows PowerShell script file name, and then try again.
Windows PowerShell
Copyright (C) 2016 Microsoft Corporation. All rights reserved.

@noahifi

This comment has been minimized.

Show comment
Hide comment
@noahifi

noahifi Feb 25, 2018

I'm going through the Stackskills online couse, "The Python Mega Course," which has a video entitled, "Setting up and Working with the Atom Editor" (4:37). The instructor appears to be using Windows 7. I'm using Windows 10. He shows how to install a useful package, "terminal Plus," and installs it. The "+" appears in the bottom of the Atom status line. I go through the same process and nothing confirms the Terminal Plus packages installs, no error message, nothing to indicate it installed successfully. I does appear in C\Users\Mike.atom.apm\terminal-plus with a folder for version 0.14.5. What is the simplest method to get terminal plus working with Atom running under Windows 10?

noahifi commented Feb 25, 2018

I'm going through the Stackskills online couse, "The Python Mega Course," which has a video entitled, "Setting up and Working with the Atom Editor" (4:37). The instructor appears to be using Windows 7. I'm using Windows 10. He shows how to install a useful package, "terminal Plus," and installs it. The "+" appears in the bottom of the Atom status line. I go through the same process and nothing confirms the Terminal Plus packages installs, no error message, nothing to indicate it installed successfully. I does appear in C\Users\Mike.atom.apm\terminal-plus with a folder for version 0.14.5. What is the simplest method to get terminal plus working with Atom running under Windows 10?

@mittalyashu

This comment has been minimized.

Show comment
Hide comment
@mittalyashu

mittalyashu Jun 10, 2018

#15 (comment)
Didn't work for me.

mittalyashu commented Jun 10, 2018

#15 (comment)
Didn't work for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment