Permalink
Browse files

bundlerize

  • Loading branch information...
1 parent 2e4b6ca commit 11af4c9464d99f537b7a77b397c4b6ff0e921f66 @jeremyw committed Sep 26, 2011
Showing with 36 additions and 92 deletions.
  1. +1 −1 Gemfile
  2. +11 −6 Gemfile.lock
  3. +3 −24 Rakefile
  4. +0 −1 VERSION
  5. +5 −0 lib/dribbble/version.rb
  6. +16 −60 swish.gemspec
View
@@ -1,4 +1,4 @@
-source "http://rubygems.org"
+source :rubygems
gem 'rake'
gemspec
View
@@ -1,21 +1,26 @@
PATH
remote: .
specs:
- swish (0.8.0)
+ swish (0.8.1)
+ crack (>= 0.1.8)
+ httparty (>= 0.6.1)
GEM
remote: http://rubygems.org/
specs:
- crack (0.1.8)
- httparty (0.7.8)
- crack (= 0.1.8)
+ crack (0.3.1)
+ httparty (0.8.0)
+ multi_json
+ multi_xml
+ multi_json (1.0.3)
+ multi_xml (0.4.0)
rake (0.9.2)
+ test-unit (2.4.0)
PLATFORMS
ruby
DEPENDENCIES
- crack (>= 0.1.8)
- httparty (>= 0.6.1)
rake
swish!
+ test-unit
View
@@ -1,23 +1,4 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "swish"
- gem.summary = %Q{A Ruby wrapper for the Dribbble API}
- gem.description = %Q{A Ruby wrapper for the Dribbble API}
- gem.email = "jeremy@weiskotten.com"
- gem.homepage = "http://github.com/jeremyw/swish"
- gem.authors = ["Jeremy Weiskotten"]
- gem.add_development_dependency "crack", ">= 0.1.8"
- gem.add_development_dependency "httparty", ">= 0.6.1"
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
+require "bundler/gem_tasks"
require 'rake/testtask'
Rake::TestTask.new(:test) do |test|
@@ -27,6 +8,8 @@ Rake::TestTask.new(:test) do |test|
test.warning = true
end
+task :default => :test
+
begin
require 'rcov/rcovtask'
Rcov::RcovTask.new do |test|
@@ -40,10 +23,6 @@ rescue LoadError
end
end
-task :test => :check_dependencies if defined?(Jeweler)
-
-task :default => :test
-
require 'rake/rdoctask'
Rake::RDocTask.new do |rdoc|
version = File.exist?('VERSION') ? File.read('VERSION') : ""
View
@@ -1 +0,0 @@
-0.8.0
View
@@ -0,0 +1,5 @@
+module Dribbble
+ module Gem
+ VERSION = "0.8.1"
+ end
+end
View
@@ -1,68 +1,24 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "dribbble/version"
Gem::Specification.new do |s|
- s.name = %q{swish}
- s.version = "0.8.0"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Jeremy Weiskotten"]
- s.date = %q{2011-03-06}
+ s.name = "swish"
+ s.version = Dribbble::Gem::VERSION
+ s.authors = ["Jeremy Weiskotten"]
+ s.email = ["jeremy@weiskotten.com"]
+ s.homepage = "https://github.com/jeremyw/swish"
+ s.summary = %q{A Ruby wrapper for the Dribbble API}
s.description = %q{A Ruby wrapper for the Dribbble API}
- s.email = %q{jeremy@weiskotten.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "lib/dribbble/base.rb",
- "lib/dribbble/comment.rb",
- "lib/dribbble/paginated_list.rb",
- "lib/dribbble/player.rb",
- "lib/dribbble/shot.rb",
- "lib/swish.rb",
- "swish.gemspec",
- "test/base_test.rb",
- "test/comment_test.rb",
- "test/helper.rb",
- "test/paginated_list_test.rb",
- "test/player_test.rb",
- "test/shot_test.rb"
- ]
- s.homepage = %q{http://github.com/jeremyw/swish}
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{A Ruby wrapper for the Dribbble API}
- s.test_files = [
- "test/base_test.rb",
- "test/comment_test.rb",
- "test/helper.rb",
- "test/paginated_list_test.rb",
- "test/player_test.rb",
- "test/shot_test.rb"
- ]
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.add_runtime_dependency(%q<crack>, [">= 0.1.8"])
+ s.add_runtime_dependency(%q<httparty>, [">= 0.6.1"])
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<crack>, [">= 0.1.8"])
- s.add_development_dependency(%q<httparty>, [">= 0.6.1"])
- else
- s.add_dependency(%q<crack>, [">= 0.1.8"])
- s.add_dependency(%q<httparty>, [">= 0.6.1"])
- end
- else
- s.add_dependency(%q<crack>, [">= 0.1.8"])
- s.add_dependency(%q<httparty>, [">= 0.6.1"])
- end
+ s.add_development_dependency "rake"
+ s.add_development_dependency "test-unit"
end
-

0 comments on commit 11af4c9

Please sign in to comment.