Permalink
Browse files

Switches to bundler for gem deployment

  • Loading branch information...
1 parent 93e2946 commit c63585451601a637cf41d7855a6049f2b5204b25 Jeroen Jacobs committed Mar 26, 2011
Showing with 41 additions and 106 deletions.
  1. +0 −5 .document
  2. +4 −0 CHANGES
  3. +3 −0 Gemfile
  4. +18 −0 Gemfile.lock
  5. +2 −46 Rakefile
  6. +14 −55 geo_ip.gemspec
View
@@ -1,5 +0,0 @@
-README.rdoc
-lib/**/*.rb
-bin/*
-features/**/*.feature
-LICENSE
View
@@ -1,3 +1,7 @@
+== 0.3.1 (in development)
+
+* Switches to bundler for gem deployment
+
== 0.3.0
* Added support for API key requirement (Thanks to seanconaty and luigi)
View
@@ -0,0 +1,3 @@
+source 'http://rubygems.org'
+
+gemspec
View
@@ -0,0 +1,18 @@
+PATH
+ remote: .
+ specs:
+ geo_ip (0.3.0)
+ json (~> 1.4.6)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ json (1.4.6)
+ rspec (1.3.1)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ geo_ip!
+ rspec (~> 1.3.0)
View
@@ -1,46 +1,2 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "geo_ip"
- gem.summary = "Retreive the geolocation of an IP address based on the ipinfodb.com webservice"
- gem.description = "A call to the ipinfodb.com will be done to retreive the geolocation based on the IP address. No need to include a database file in the application."
- gem.email = "gems@jeroenj.be"
- gem.homepage = "http://github.com/jeroenj/geo_ip"
- gem.authors = ["Jeroen Jacobs"]
- gem.add_dependency "json", "~> 1.4.6"
- gem.add_development_dependency "rspec", "~> 1.3.0"
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
-
-require 'spec/rake/spectask'
-Spec::Rake::SpecTask.new(:spec) do |spec|
- spec.libs << 'lib' << 'spec'
- spec.spec_files = FileList['spec/**/*_spec.rb']
-end
-
-Spec::Rake::SpecTask.new(:rcov) do |spec|
- spec.libs << 'lib' << 'spec'
- spec.pattern = 'spec/**/*_spec.rb'
- spec.rcov = true
-end
-
-task :spec => :check_dependencies
-
-task :default => :spec
-
-require 'rake/rdoctask'
-Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
- rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "geo_ip #{version}"
- rdoc.rdoc_files.include('README*')
- rdoc.rdoc_files.include('lib/**/*.rb')
-end
+require 'bundler'
+Bundler::GemHelper.install_tasks
View
@@ -1,61 +1,20 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.push File.expand_path('../lib', __FILE__)
Gem::Specification.new do |s|
- s.name = %q{geo_ip}
- s.version = "0.3.0"
+ s.name = 'geo_ip'
+ s.version = '0.3.0'
+ s.platform = Gem::Platform::RUBY
+ s.authors = ['Jeroen Jacobs']
+ s.email = 'gems@jeroenj.be'
+ s.homepage = 'http://jeroenj.be'
+ s.summary = 'Retreive the geolocation of an IP address based on the ipinfodb.com webservice'
+ s.description = 'A call to the ipinfodb.com will be done to retreive the geolocation based on the IP address. No need to include a database file in the application.'
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Jeroen Jacobs"]
- s.date = %q{2010-11-16}
- s.description = %q{A call to the ipinfodb.com will be done to retreive the geolocation based on the IP address. No need to include a database file in the application.}
- s.email = %q{gems@jeroenj.be}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- ".gitignore",
- "CHANGES",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "geo_ip.gemspec",
- "init.rb",
- "lib/geo_ip.rb",
- "spec/api.yml.example",
- "spec/geo_ip_spec.rb",
- "spec/spec.opts",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/jeroenj/geo_ip}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Retreive the geolocation of an IP address based on the ipinfodb.com webservice}
- s.test_files = [
- "spec/geo_ip_spec.rb",
- "spec/spec_helper.rb"
- ]
+ s.files = Dir['README.rdoc', 'CHANGES', 'LICENSE', 'lib/**/*']
+ s.test_files = Dir.glob('spec/**/*')
+ s.require_paths = ['lib']
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<json>, ["~> 1.4.6"])
- s.add_development_dependency(%q<rspec>, ["~> 1.3.0"])
- else
- s.add_dependency(%q<json>, ["~> 1.4.6"])
- s.add_dependency(%q<rspec>, ["~> 1.3.0"])
- end
- else
- s.add_dependency(%q<json>, ["~> 1.4.6"])
- s.add_dependency(%q<rspec>, ["~> 1.3.0"])
- end
+ s.add_dependency 'json', '~> 1.4.6'
+ s.add_development_dependency 'rspec', '~> 1.3.0'
end
-

0 comments on commit c635854

Please sign in to comment.