Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Uncaught ReferenceError: QRErrorCorrectLevel is not defined #23

Open
fotoflo opened this Issue · 3 comments

3 participants

@fotoflo

i've followed the directions as mentioned in the readme, but am getting this issue

jQuery.qrcode.js:15Uncaught ReferenceError: QRErrorCorrectLevel is not defined, on line 15

@fotoflo

I think i've fixed that by changing line 15:

        correctLevel    : QRErrorCorrectLevel.H,

to
correctLevel : "QRErrorCorrectLevel.H",

@jwittkoski

@fotoflo The fix you listed does not set the QRErrorCorrectLevel as you expect (although it does get rid of the error).

It seems like you would only see this error if you use the src/jquery.qrcode.js file directly instead of the jquery.qrcode.min.js file (which contains both src/jquery.qrcode.js and src/qrcode.js).

See the Makefile for how they are combined.

@j717273419

Yeah!

Use jquery.qrcode.min.js,

It's worked!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.