Permalink
Browse files

1) Fix os dependent elements of high-level interface

2) Update to glib 2.38 , gtk 2.24, including fixing cfwrapper.py
3) Update plplot routines to 5.9.10 API (REAL line widths)
  • Loading branch information...
1 parent a17736b commit ce589c3bcb6432f7555f4221cafb9e20014feaf1 @jtappin jtappin committed Oct 29, 2013
View
@@ -207,9 +207,11 @@ subroutine plot2()
! Draw the line
call plcol0(3)
- call plwid(2)
+! call plwid(2)
+ call plwidth(2.0_plflt)
call plline( x, y )
- call plwid(1)
+! call plwid(1)
+ call plwidth(1.0_plflt)
end subroutine plot2
View
@@ -128,11 +128,10 @@ subroutine plot1(type)
real(kind=plflt) legend_width, legend_height
integer opt_array(2), text_colors(2), line_colors(2), &
- line_styles(2), line_widths(2), symbol_colors(2), &
- symbol_numbers(2)
- real(kind=plflt) symbol_scales(2), box_scales(0)
+ line_styles(2), symbol_colors(2), symbol_numbers(2)
+ real(kind=plflt) symbol_scales(2), box_scales(0), line_widths(2)
integer box_colors(0), box_patterns(0)
- integer box_line_widths(0)
+ real(kind=plflt) box_line_widths(0)
character(len=20) text(2)
character(len=1) symbols(2)
@@ -191,7 +190,8 @@ subroutine plot1(type)
text(1) = 'Amplitude'
line_colors(1) = 2
line_styles(1) = 1
- line_widths(1) = 1
+! line_widths(1) = 1
+ line_widths(1) = 1.0_plflt
! note from the above opt_array the first symbol (and box) indices
! do not have to be specified
@@ -201,7 +201,8 @@ subroutine plot1(type)
text(2) = 'Phase shift'
line_colors(2) = 3
line_styles(2) = 1
- line_widths(2) = 1
+! line_widths(2) = 1
+ line_widths(2) = 1.0_plflt
symbol_colors(2) = 3
symbol_scales(2) = 1.0
symbol_numbers(2) = 4
Oops, something went wrong.

0 comments on commit ce589c3

Please sign in to comment.