Skip to content
Permalink
Browse files
chore: drop node@6 support
BREAKING CHANGE: Minimum node version is now 8

closes #410
  • Loading branch information
G-Rath committed Oct 27, 2019
1 parent a7ba3e4 commit 2ce233c845fccd47bd632370cf0126b2d5cdaa35
Showing with 3 additions and 4 deletions.
  1. +1 −1 .github/workflows/nodejs.yml
  2. +0 −1 .travis.yml
  3. +1 −1 babel.config.js
  4. +1 −1 package.json
@@ -16,7 +16,7 @@ jobs:
strategy:
fail-fast: false
matrix:
node-version: [6.x, 8.x, 10.x, 12.x, 13.x]
node-version: [8.x, 10.x, 12.x, 13.x]
runs-on: ubuntu-latest

steps:
@@ -3,7 +3,6 @@ node_js:
- 12
- 10
- 8
- 6
- node
before_install:
- curl -o- -L https://yarnpkg.com/install.sh | bash
@@ -5,6 +5,6 @@ module.exports = {
plugins: ['replace-ts-export-assignment'],
presets: [
'@babel/preset-typescript',
['@babel/preset-env', { targets: { node: 6 } }],
['@babel/preset-env', { targets: { node: 8 } }],
],
};
@@ -20,7 +20,7 @@
],
"main": "lib/",
"engines": {
"node": ">=6"
"node": ">=8"
},
"peerDependencies": {
"eslint": ">=5"

0 comments on commit 2ce233c

Please sign in to comment.