New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

install-plugin fails due to: "module not found: org.springframework.osgi#spring-osgi-core;2.0.0.M1" #15

Closed
lemnitram opened this Issue Jul 20, 2010 · 5 comments

Comments

Projects
None yet
2 participants
@lemnitram

lemnitram commented Jul 20, 2010

Is there additional set up to get the plugin to install?

(using grails 1.3.3)

end of error message:

        ::::::::::::::::::::::::::::::::::::::::::::::

    ::          UNRESOLVED DEPENDENCIES         ::

    ::::::::::::::::::::::::::::::::::::::::::::::

    :: org.springframework.osgi#spring-osgi-core;2.0.0.M1: not found

    :: org.springframework.osgi#spring-osgi-io;2.0.0.M1: not found

    ::::::::::::::::::::::::::::::::::::::::::::::
@jetztgradnet

This comment has been minimized.

Show comment
Hide comment
@jetztgradnet

jetztgradnet Jul 20, 2010

Owner

Sorry for this failure.

The Spring DM snapshot modules seem to have been removed from SpringSource Enterprise Bundle Repository. I just posted at the SpringSource Forum.

If this change is permanent, I need to migrate the OSGi plugin to Eclipse Gemini Blueprint sooner than planned.

Owner

jetztgradnet commented Jul 20, 2010

Sorry for this failure.

The Spring DM snapshot modules seem to have been removed from SpringSource Enterprise Bundle Repository. I just posted at the SpringSource Forum.

If this change is permanent, I need to migrate the OSGi plugin to Eclipse Gemini Blueprint sooner than planned.

@lemnitram

This comment has been minimized.

Show comment
Hide comment
@lemnitram

lemnitram Jul 21, 2010

Thanks for the reply. No problem at all.

It looks like I may have some time to try to pull in blueprint if you are busy.

lemnitram commented Jul 21, 2010

Thanks for the reply. No problem at all.

It looks like I may have some time to try to pull in blueprint if you are busy.

@jetztgradnet

This comment has been minimized.

Show comment
Hide comment
@jetztgradnet

jetztgradnet Jul 21, 2010

Owner

I'll try to do this tonight, but can't promise.

Fell free to do this, if you want.

Basically, you would need to change BuildConfig.groovy to include a new Ivy resolver for zodiac.springsource.com and change version and bundle name around line 52 and 55.

Additionally changes for scripts/_Osgi.groovy:

  • (from line 137): version and bundle names; please note, that Gemini currently provides only a web service based on Tomcat, so that needs to be changed as well
  • (from line 659): package name in generated logging config

Additionally changes for scripts/_Events.groovy:

  • (lines 12, 266, 267) version and package names

I hope that's all, but you simply need to try it and work from exceptions etc.

Owner

jetztgradnet commented Jul 21, 2010

I'll try to do this tonight, but can't promise.

Fell free to do this, if you want.

Basically, you would need to change BuildConfig.groovy to include a new Ivy resolver for zodiac.springsource.com and change version and bundle name around line 52 and 55.

Additionally changes for scripts/_Osgi.groovy:

  • (from line 137): version and bundle names; please note, that Gemini currently provides only a web service based on Tomcat, so that needs to be changed as well
  • (from line 659): package name in generated logging config

Additionally changes for scripts/_Events.groovy:

  • (lines 12, 266, 267) version and package names

I hope that's all, but you simply need to try it and work from exceptions etc.

@jetztgradnet

This comment has been minimized.

Show comment
Hide comment
@jetztgradnet

jetztgradnet Jul 26, 2010

Owner

Fixed with 756555a

Owner

jetztgradnet commented Jul 26, 2010

Fixed with 756555a

@jetztgradnet

This comment has been minimized.

Show comment
Hide comment
@jetztgradnet

jetztgradnet Jul 26, 2010

Owner

Please use Grails OSGi plugin 0.2.1 or later, which contains the fix for this issue.

Owner

jetztgradnet commented Jul 26, 2010

Please use Grails OSGi plugin 0.2.1 or later, which contains the fix for this issue.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment