New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update package.json #1

Merged
merged 1 commit into from Nov 5, 2011

Conversation

Projects
None yet
4 participants
@deedubs

deedubs commented Nov 5, 2011

Had to make a couple changes to make this installable on node v0.4.12 and npm 1.0.9-1

@jfhbrook

This comment has been minimized.

Show comment
Hide comment
@jfhbrook

jfhbrook Nov 5, 2011

Owner

Alright, sure.

I had a conversation with @substack the other day where we considered the idea that "engines" is actually kinda bad, because it can cause problems exactly like this. I've started thinking about using "*" on engines, but I'm not 100% convinced I thought of everything.

Requesting comments.

Owner

jfhbrook commented Nov 5, 2011

Alright, sure.

I had a conversation with @substack the other day where we considered the idea that "engines" is actually kinda bad, because it can cause problems exactly like this. I've started thinking about using "*" on engines, but I'm not 100% convinced I thought of everything.

Requesting comments.

jfhbrook added a commit that referenced this pull request Nov 5, 2011

Merge pull request #1 from rocketlabsdev/master
Update package.json.

First auto-merge, by the way.

@jfhbrook jfhbrook merged commit d918237 into jfhbrook:master Nov 5, 2011

@deedubs

This comment has been minimized.

Show comment
Hide comment
@deedubs

deedubs Nov 5, 2011

I think if we test against 0.6 and everything is solid that'd be safe

Sent from my iPad

On 2011-11-05, at 3:45 AM, Joshua Holbrook
reply@reply.github.com
wrote:

Alright, sure.

I had a conversation with @substack the other day where we considered the idea that "engines" is actually kinda bad, because it can cause problems exactly like this. I've started thinking about using "*" on engines, but I'm not 100% convinced I thought of everything.

Requesting comments.


Reply to this email directly or view it on GitHub:
#1 (comment)

deedubs commented Nov 5, 2011

I think if we test against 0.6 and everything is solid that'd be safe

Sent from my iPad

On 2011-11-05, at 3:45 AM, Joshua Holbrook
reply@reply.github.com
wrote:

Alright, sure.

I had a conversation with @substack the other day where we considered the idea that "engines" is actually kinda bad, because it can cause problems exactly like this. I've started thinking about using "*" on engines, but I'm not 100% convinced I thought of everything.

Requesting comments.


Reply to this email directly or view it on GitHub:
#1 (comment)

@isaacs

This comment has been minimized.

Show comment
Hide comment
@isaacs

isaacs Nov 6, 2011

npm 1.0.9-1 is super crazy old. Please update to 1.0.104.

~0.4.9 is the same as 0.4.x >=0.4.9. The fact that npm 1.0.9 didn't know this is a bug in npm, not in sendgrid.

If the program works in node 0.6, then you should update the engines field appropriately. If sendgrid is using node APIs that aren't supported in 0.5 or 0.6, then it ought to prevent you from installing it with that version of node.

isaacs commented Nov 6, 2011

npm 1.0.9-1 is super crazy old. Please update to 1.0.104.

~0.4.9 is the same as 0.4.x >=0.4.9. The fact that npm 1.0.9 didn't know this is a bug in npm, not in sendgrid.

If the program works in node 0.6, then you should update the engines field appropriately. If sendgrid is using node APIs that aren't supported in 0.5 or 0.6, then it ought to prevent you from installing it with that version of node.

@deedubs

This comment has been minimized.

Show comment
Hide comment
@deedubs

deedubs Nov 6, 2011

Sorry about that jesusabdullah!

I think that this should be isolated from much of the 0.4.x to 0.6.x changes by its use of request.js for the bulk of the work.

deedubs commented Nov 6, 2011

Sorry about that jesusabdullah!

I think that this should be isolated from much of the 0.4.x to 0.6.x changes by its use of request.js for the bulk of the work.

@jfhbrook

This comment has been minimized.

Show comment
Hide comment
@jfhbrook

jfhbrook Nov 6, 2011

Owner

If the program works in node 0.6, then you should update the engines field appropriately. If sendgrid is using node APIs that aren't supported in 0.5 or 0.6, then it ought to prevent you from installing it with that version of node.

I think that this should be isolated from much of the 0.4.x to 0.6.x changes by its use of request.js for the bulk of the work.

I suspect this as well.

I propose changing the engines field to "*" until I hear that it's not cross-compatible.

Owner

jfhbrook commented Nov 6, 2011

If the program works in node 0.6, then you should update the engines field appropriately. If sendgrid is using node APIs that aren't supported in 0.5 or 0.6, then it ought to prevent you from installing it with that version of node.

I think that this should be isolated from much of the 0.4.x to 0.6.x changes by its use of request.js for the bulk of the work.

I suspect this as well.

I propose changing the engines field to "*" until I hear that it's not cross-compatible.

@goldfire

This comment has been minimized.

Show comment
Hide comment
@goldfire

goldfire Nov 30, 2011

I've been using it on 0.6.3 with no problems. I couldn't install using npm though because package.json hasn't been updated. Have you found issues on 0.6.x?

goldfire commented Nov 30, 2011

I've been using it on 0.6.3 with no problems. I couldn't install using npm though because package.json hasn't been updated. Have you found issues on 0.6.x?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment