Permalink
Browse files

Moved documentation requirements to a different requirements file.

  • Loading branch information...
1 parent 870f284 commit 6af3f5a423d05f0b24f34be91d5086ef30ea2859 @jfinkels committed Mar 27, 2012
Showing with 12 additions and 3 deletions.
  1. +6 −1 README.md
  2. +6 −0 requirements-doc.txt
  3. +0 −2 requirements.txt
View
7 README.md
@@ -110,7 +110,12 @@ the documentation:
* [Sphinx][6]
* [sphinxcontrib-httpdomain-withpatch][7]
-Using `pip` is probably the easiest way to install these:
+These requirements are also listed in the `requirements-doc.txt` file. Using
+`pip` is probably the easiest way to install these:
+
+ pip install -r requirements-doc.txt
+
+or
pip install sphinx "sphinxcontrib-httpdomain-withpatch==1.1.6-patch2"
View
6 requirements-doc.txt
@@ -0,0 +1,6 @@
+# recursively require all the normal packages required by the code
+-r requirements.txt
+
+# plus...
+sphinx
+sphinxcontrib-httpdomain-withpatch==1.1.6-patch2
View
2 requirements.txt
@@ -2,5 +2,3 @@ flask>=0.7
elixir
sqlalchemy
python-dateutil<2.0
-sphinx
-sphinxcontrib-httpdomain-withpatch

0 comments on commit 6af3f5a

Please sign in to comment.