Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Removing Python 2.5 from Travis config since Jinja2 no longer supports it #215

Merged
merged 1 commit into from Jul 25, 2013

Conversation

@croach
Copy link
Contributor

croach commented Jun 1, 2013

The latest versions of Jinja2 no longer support Python 2.5 [1, 2,
3]. Since Jinja2 is an integral part of Flask, this would also mean
that Flask no longer supports versions of Python prior to 2.6. Since
Flask no longer supports versions of Python prior to 2.6, plugins for
Flask do not need to support them either and so, the 2.5 Travis test
can be removed.

…ports it

The latest versions of Jinja2 no longer support Python 2.5 [[1], [2],
[3]]. Since Jinja2 is an integral part of Flask, this would also mean
that Flask no longer supports versions of Python prior to 2.6. Since
Flask no longer supports versions of Python prior to 2.6, plugins for
Flask do not need to support them either and so, the 2.5 Travis test
can be removed.

[1]: pallets/jinja#185 (comment)
[2]: pallets/jinja@b89d1a8
[3]: pallets/jinja@8bdc65d
@jfinkels

This comment has been minimized.

Copy link
Owner

jfinkels commented Jun 12, 2013

I prefer to do this only when there is a tagged and published version of Flask that removes support for Python 2.5, so I'll revisit this again when the next version of Flask is released (as of today, the next version will be 0.10).

@croach

This comment has been minimized.

Copy link
Contributor Author

croach commented Jun 12, 2013

You may want to do that a little earlier. The current Flask Installation docs specify that you must have Python 2.6 or higher installed to install Flask. Also, while looking through some of the Flask-Restless code, I noticed some code that currently only works with Python 2.7+ (#217).

@glyphobet glyphobet referenced this pull request Jun 13, 2013
@croach

This comment has been minimized.

Copy link
Contributor Author

croach commented Jun 14, 2013

What a coincidence, Flask was just updated to 0.10 earlier today. It looks like Python 2.5 is officially no longer supported. Here's the blog post talking about the update: http://lucumr.pocoo.org/2013/6/13/werkzeug-and-flask-releases/.

@glyphobet

This comment has been minimized.

Copy link
Contributor

glyphobet commented Jun 30, 2013

This should be merged. It is causing all the builds to fail.

@jfinkels

This comment has been minimized.

Copy link
Owner

jfinkels commented Jul 25, 2013

Let's do it!

jfinkels added a commit that referenced this pull request Jul 25, 2013
Removing Python 2.5 from Travis config since Jinja2 no longer supports it
@jfinkels jfinkels merged commit b5ef173 into jfinkels:master Jul 25, 2013
1 check passed
1 check passed
default The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.