This repository has been archived by the owner. It is now read-only.

GLM Include Error #209

Closed
Craytor opened this Issue Oct 14, 2015 · 18 comments

Comments

Projects
None yet
8 participants
@Craytor
Copy link

Craytor commented Oct 14, 2015

Hello, I'm fairly new to using pods. I'm currently getting the following error,
screen shot on 2015-10-13 at 20_29_39
it has to do with this #include "type_half.inl" more specifically not being found.

I'm not sure what to do, any help would be appreciated. I don't know if this is connected at all, but I have an error when doing pod install, which is this:
screen shot on 2015-10-13 at 20_33_18

Thanks!

@andwun

This comment has been minimized.

Copy link

andwun commented Oct 14, 2015

This seems to be a ridiculous incompatibility introduced with cocoapods v0.39.0 (CocoaPods/CocoaPods#4057).
Downgrading back to v0.38.2 got it working again for now.

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 14, 2015

How do you downgrade back to v0.38.2? I'm fairly new to this.

Thanks!

Sent from my iPhone

On Oct 14, 2015, at 8:31 AM, Andreas Wunderlich notifications@github.com wrote:

This seems to be a ridiculous incompatibility introduced with cocoapods v0.39.0.
Downgrading back to v0.38.2 got working again for me for now.


Reply to this email directly or view it on GitHub.

@andwun

This comment has been minimized.

Copy link

andwun commented Oct 14, 2015

This worked for me:

gem install cocoapods -v 0.38.2
gem uninstall cocoapods -v 0.39.0

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 14, 2015

Right, so I did that, and now I get this ugly mess.
screen shot 2015-10-14 at 9 14 45 am

Am I doing something wrong?

@andwun

This comment has been minimized.

Copy link

andwun commented Oct 14, 2015

Well, the middle part (lines 2 to 10) is just the update notification. Ignore that for now.
However, I think you cut off the interesting part below "Unable to satisfy the following requirements:"
Please post whats below there + your Podfile.

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 14, 2015

screen shot 2015-10-14 at 9 14 45 am

Pod file:

platform :ios, '8.0'

source 'https://github.com/CocoaPods/Specs.git'

# See: http://guides.cocoapods.org/making/making-a-cocoapod.html#release
# Once the pod has been released, use a version number here instead of a path.
#pod 'VideoCore', '~>0.3.0.3'
pod 'VideoCore', path: '../..'

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 14, 2015

I fixed it by uncommenting the first VideoCore line, and commenting the second.

pod 'VideoCore', '~>0.3.0.3'
#pod 'VideoCore', path: '../..'
@andwun

This comment has been minimized.

Copy link

andwun commented Oct 14, 2015

Yeah, also note that the version is duplicated.
I think this is what you wanted:

pod 'VideoCore', '~>0.3'

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 14, 2015

Ah, good point. So that time I was able to actually run the app, and it actually worked! So, are these warnings okay?
screen shot 2015-10-14 at 9 56 21 am

@JALsnipe

This comment has been minimized.

Copy link
Contributor

JALsnipe commented Oct 14, 2015

Yes, those warnings are fine. The code is setup to support legacy SDKs. The deprecated methods are only called if their newer counterparts are unavailable.

@dourgulf

This comment has been minimized.

Copy link
Contributor

dourgulf commented Oct 15, 2015

I solved this problem by change the search path setting in Pods project. Just remove all ""${PODS_ROOT}/Headers/Private" in “Header Search Paths"

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 15, 2015

So when I go to use VideoCore with a brand new project, I keep getting error about VCSessionDelegate "use of undeclared type 'VCSessionDelegate'". I have no clue what this means. I have set the project up with the Pods file, and I'm pretty sure video core is installed.
screen shot 2015-10-14 at 11 56 47 pm

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 15, 2015

Fixed... Don't forget to go to build settings and enter the bridging file path. This should really be in the docs.

@Craytor

This comment has been minimized.

Copy link
Author

Craytor commented Oct 18, 2015

This has been solved (as mentioned way above).

@Craytor Craytor closed this Oct 18, 2015

@AkshayBudhiraja

This comment has been minimized.

Copy link

AkshayBudhiraja commented Oct 28, 2015

@Craytor Hey, getting the same error as you did in the last comment. Could you elaborate more on what you meant/did by entering the bridging file path?

Thanks!

@sidetlw

This comment has been minimized.

Copy link

sidetlw commented Mar 22, 2016

what's the mean of 'Don't forget to go to build settings and enter the bridging file path.'?what to do exactly?

@AgarwalMilan

This comment has been minimized.

Copy link

AgarwalMilan commented Apr 15, 2016

dourgulf has given the best and quickest solution to this problem.

@ZenonHuang

This comment has been minimized.

Copy link

ZenonHuang commented May 7, 2016

@dourgulf has given the best and quickest solution to this problem

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.