Build error #12

Open
conchis opened this Issue Jul 4, 2010 · 1 comment

Comments

Projects
None yet
2 participants

conchis commented Jul 4, 2010

While installing the latest gitit with "cabal install gitit" under OS X 10.6.4 and GHC 6.10.4, the following error occurred:

oak:Applications jonathan$ cabal install gitit
Resolving dependencies...
Configuring strict-concurrency-0.2.3...
Preprocessing library strict-concurrency-0.2.3...
Building strict-concurrency-0.2.3...

Control/Concurrent/MVar/Strict.hs:46:7:
Could not find module Control.OldException': it is a member of the hidden packagebase'
Use -v to see a list of the files searched for.

cabal: Error: some packages failed to install

Any idea how to fix this? Thanks!

Owner

jgm commented Jul 4, 2010

I'm not sure off hand -- I've switched to GHC 6.12 (which I recommend), so I can't try to reproduce this. Since the build is failing on the strict-concurrency package, you might try querying its author. I find the message mysterious myself, since the package does explicitly "build-depend" on base. Probably this has to do with the changes in the exception system from 6.10 to 6.12.

segasai pushed a commit to segasai/gitit that referenced this issue Oct 4, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment