Support for happstack-server 6.3.1? #276

Closed
peti opened this Issue Nov 15, 2011 · 14 comments

2 participants

@peti

Could you please add support for the latest version of happstack-server?

http://hackage.haskell.org/package/happstack-server

@jgm
Owner
@peti
@jgm
Owner
@peti
@jgm
Owner
@peti
@jgm
Owner
@peti
@peti

happstack-server is now at 6.4.5. Could you please release a new version of gitit?

@jgm
Owner

With the last batch of changes, gitit depends on pandoc 1.9, which depends on the still unreleased new version of citeproc-hs. Sorry, you'll have to be patient while citeproc-hs, h-k 0.4, pandoc 1.9 come out -- and then I can release a new gitit. I can't predict a timetable, because citeproc-hs is out of my hands....

@peti

happstack-server is now at 6.5.3. Could you please release a new version of gitit that support that update?

@peti

Hi John, it seems like all the other packages on which gitit depends have released new versions. Meanwhile, happstack-server is at version 6.6.3. Do you believe there's going to be a new release of gitit in the near future that supports recent versions of happstack?

@jgm
Owner
@peti

For the time being, I have updated happstack-server in NixOS. Unfortunately, that breaks the gitit build, but users can still install it using cabal install, of course, so I guess that's not a major problem. When the update comes out, then we'll update gitit to fix the build in NixOS. Thank you for your efforts.

@peti peti closed this Feb 20, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment