Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #496 from markwright/master

changes for blaze-html 0.5
  • Loading branch information...
commit a0fa8f92f1eb1e2678f1d1e1bd9f86d6a1bfa9d5 2 parents 869ff43 + 471d4dc
@jgm authored
View
27 pandoc.cabal
@@ -185,6 +185,9 @@ Flag library
Flag tests
Description: Build test-pandoc.
Default: False
+Flag blaze_html_0_5
+ Description: Use blaze-html 0.5 and blaze-markup 0.5
+ Default: False
Library
-- Note: the following is duplicated in all stanzas.
@@ -192,7 +195,6 @@ Library
-- BEGIN DUPLICATED SECTION
Build-Depends: containers >= 0.1 && < 0.5,
parsec >= 3.1 && < 3.2,
- blaze-html >= 0.4.3.0 && < 0.5,
mtl >= 1.1 && < 2.2,
network >= 2 && < 2.4,
filepath >= 1.1 && < 1.4,
@@ -216,6 +218,13 @@ Library
zlib >= 0.5 && < 0.6,
highlighting-kate >= 0.5.0.2 && < 0.6,
temporary >= 1.1 && < 1.2
+ if flag(blaze_html_0_5)
+ build-depends:
+ blaze-html >= 0.5 && < 0.6,
+ blaze-markup >= 0.5.1 && < 0.6
+ else
+ build-depends:
+ blaze-html >= 0.4.3.0 && < 0.5
if impl(ghc >= 6.10)
Build-depends: base >= 4 && < 5, syb >= 0.1 && < 0.4
else
@@ -291,7 +300,6 @@ Executable pandoc
-- BEGIN DUPLICATED SECTION
Build-Depends: containers >= 0.1 && < 0.5,
parsec >= 3.1 && < 3.2,
- blaze-html >= 0.4.3.0 && < 0.5,
mtl >= 1.1 && < 2.2,
network >= 2 && < 2.4,
filepath >= 1.1 && < 1.4,
@@ -315,6 +323,13 @@ Executable pandoc
zlib >= 0.5 && < 0.6,
highlighting-kate >= 0.5.0.2 && < 0.6,
temporary >= 1.1 && < 1.2
+ if flag(blaze_html_0_5)
+ build-depends:
+ blaze-html >= 0.5 && < 0.6,
+ blaze-markup >= 0.5.1 && < 0.6
+ else
+ build-depends:
+ blaze-html >= 0.4.3.0 && < 0.5
if impl(ghc >= 6.10)
Build-depends: base >= 4 && < 5, syb >= 0.1 && < 0.4
else
@@ -349,7 +364,6 @@ Executable test-pandoc
-- BEGIN DUPLICATED SECTION
Build-Depends: containers >= 0.1 && < 0.5,
parsec >= 3.1 && < 3.2,
- blaze-html >= 0.4.3.0 && < 0.5,
mtl >= 1.1 && < 2.2,
network >= 2 && < 2.4,
filepath >= 1.1 && < 1.4,
@@ -373,6 +387,13 @@ Executable test-pandoc
zlib >= 0.5 && < 0.6,
highlighting-kate >= 0.5.0.2 && < 0.6,
temporary >= 1.1 && < 1.2
+ if flag(blaze_html_0_5)
+ build-depends:
+ blaze-html >= 0.5 && < 0.6,
+ blaze-markup >= 0.5.1 && < 0.6
+ else
+ build-depends:
+ blaze-html >= 0.4.3.0 && < 0.5
if impl(ghc >= 6.10)
Build-depends: base >= 4 && < 5, syb >= 0.1 && < 0.4
else
View
7 src/Text/Pandoc/Templates.hs
@@ -1,4 +1,4 @@
-{-# LANGUAGE TypeSynonymInstances, FlexibleInstances #-}
+{-# LANGUAGE TypeSynonymInstances, FlexibleInstances, CPP #-}
{-
Copyright (C) 2009-2010 John MacFarlane <jgm@berkeley.edu>
@@ -72,7 +72,12 @@ import Text.ParserCombinators.Parsec
import Control.Monad (liftM, when, forM)
import System.FilePath
import Data.List (intercalate, intersperse)
+#if MIN_VERSION_blaze_html(0,5,0)
+import Text.Blaze.Html (Html)
+import Text.Blaze.Internal (preEscapedString)
+#else
import Text.Blaze (preEscapedString, Html)
+#endif
import Data.ByteString.Lazy.UTF8 (ByteString, fromString)
import Text.Pandoc.Shared (readDataFile)
import qualified Control.Exception.Extensible as E (try, IOException)
View
7 src/Text/Pandoc/Writers/HTML.hs
@@ -1,4 +1,4 @@
-{-# LANGUAGE OverloadedStrings #-}
+{-# LANGUAGE OverloadedStrings, CPP #-}
{-# OPTIONS_GHC -fno-warn-deprecations #-}
{-
Copyright (C) 2006-2010 John MacFarlane <jgm@berkeley.edu>
@@ -46,7 +46,12 @@ import Data.List ( isPrefixOf, intersperse )
import Data.String ( fromString )
import Data.Maybe ( catMaybes )
import Control.Monad.State
+#if MIN_VERSION_blaze_html(0,5,0)
+import Text.Blaze.Html hiding(contents)
+import Text.Blaze.Internal(preEscapedString)
+#else
import Text.Blaze
+#endif
import qualified Text.Blaze.Html5 as H5
import qualified Text.Blaze.XHtml1.Transitional as H
import qualified Text.Blaze.XHtml1.Transitional.Attributes as A
Please sign in to comment.
Something went wrong with that request. Please try again.