Skip to content
Browse files

Updated to be able to use pandoc 1.16.

  • Loading branch information...
1 parent c259e86 commit ccc66d606242306addaaf49a181bc62e46c2a562 @jgm committed
Showing with 12 additions and 5 deletions.
  1. +4 −0 changelog
  2. +4 −1 stack.yaml
  3. +4 −4 yst.cabal
View
4 changelog
@@ -1,3 +1,7 @@
+yst 0.5.1 (released 02 Jan 2015)
+
+ * Allow building with pandoc 1.16.x.
+
yst 0.5.0.4 (released 01 Jul 2015)
* Allow building with pandoc 1.15.x.
View
5 stack.yaml
@@ -1,6 +1,9 @@
packages:
- '.'
-resolver: lts-3.10
+resolver: lts-3.20
extra-deps:
+- pandoc-1.16
+- pandoc-types-1.16
- HDBC-2.4.0.1
- HDBC-sqlite3-2.3.3.1
+- cmark-0.5.0
View
8 yst.cabal
@@ -1,5 +1,5 @@
name: yst
-version: 0.5.0.4
+version: 0.5.1
Tested-With: GHC == 7.8.3
Cabal-version: >= 1.8
build-type: Simple
@@ -49,15 +49,15 @@ Executable yst
hs-source-dirs: .
main-is: yst.hs
other-modules: Yst.Types, Yst.Yaml, Yst.Util, Yst.Data, Yst.Config,
- Yst.Render, Yst.Build, Yst.CSV, Yst.Sqlite3
+ Yst.Render, Yst.Build, Yst.CSV, Yst.Sqlite3, Paths_yst
build-depends: base >=3 && < 5, unordered-containers,
HStringTemplate >= 0.6.1 && < 0.6.9 || > 0.6.11 && < 0.9,
- yaml, csv, aeson >= 0.7 && < 0.10, text,
+ yaml, csv, aeson >= 0.7 && < 0.11, text,
scientific >= 0.2 && < 0.4,
filepath, containers, directory, time,
old-locale, old-time, parsec,
lucid >= 2.9 && < 2.10,
- pandoc >= 1.10 && < 1.16,
+ pandoc >= 1.10 && < 1.17,
split, HDBC, HDBC-sqlite3
extensions: CPP
if impl(ghc >= 6.12)

0 comments on commit ccc66d6

Please sign in to comment.
Something went wrong with that request. Please try again.