Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Build plugin for TeamSpeak 3.1 beta #26

Open
jhakonen opened this issue Sep 21, 2016 · 7 comments

Comments

Projects
None yet
2 participants
@jhakonen
Copy link
Owner

commented Sep 21, 2016

TeamSpeak has a new version incoming. 3.1 is currently in beta phase.
This was reported by ChrTok at http://aslain.com/index.php?/topic/6852-tessumod-incompatible/

TeamSpeak 3.1 Release notes and feedback thread:
http://forum.teamspeak.com/threads/126565-Discussion-TeamSpeak-3-Client-3-1-BETA

TeamSpeak plugin interface changes:
TeamSpeak-Systems/ts3client-pluginsdk@aa05106...db1fc56

The new version is build with Visual Studio 2015.

To support the new version we should have a separate feature branch which contains changes:

  • Install Visual Studio 2015 (instead of 2013)
  • Build Qt and OpenAl Soft with VS2015.
  • Update TeamSpeak's Plugin SDK
  • Whatever code changes needed to make the plugin compile and behave nicely

Might be best to release the plugin as a separate download and instruct users to install that one instead of the plugin distributed within mod's archive if they have TeamSpeak 3.1 installed.

Integrate the feature branch back to master when TeamSpeak releases the 3.1 to stable channel.

jhakonen added a commit that referenced this issue Sep 22, 2016

@Miscni

This comment has been minimized.

Copy link

commented Jan 30, 2017

Been looking it over, and I am getting issues on OBC and OBS, I would gladly admit, that it could be a error 39½ from my side.

@jhakonen

This comment has been minimized.

Copy link
Owner Author

commented Jan 30, 2017

Hi Miscni,

What is OBC or OBS?

@Miscni

This comment has been minimized.

Copy link

commented Jan 30, 2017

your code is being use here
https://obsproject.com/forum/resources/teamspeak-3-plugin.40/ (Open Broadcaster Classic)
and
https://obsproject.com/forum/resources/teamspeak-3-studio-plugin.448/ (Open Broadcaster Studio)
it is your code there is being used.

@jhakonen

This comment has been minimized.

Copy link
Owner Author

commented Jan 30, 2017

Umm, I think you have wrong project. The OBS plugin page refers to this project:
https://github.com/adocilesloth/TS3StudioPlugin

@Miscni

This comment has been minimized.

Copy link

commented Jan 30, 2017

I know, but I was refered into here, because some of the base code, was from your work

@jhakonen

This comment has been minimized.

Copy link
Owner Author

commented Jan 30, 2017

I think there is some kind of mixup. The Tessumod doesn't have really anything to do with OBS. I checked the code of two plugins, but I don't see anything even closely familiar about them. They are plugins to OBS, while the plugin related to this issue is a plugin to Teamspeak. They don't really have anything in common.

@Miscni

This comment has been minimized.

Copy link

commented Jan 30, 2017

hmmm.... Dont understand it then, oh well then I just have to go back to the drawing board, and see if I can fix the overlay. Just needed the overlay either from ts or OBS.
Sorry for takeing your time mate. Cheers
PS. Let me know, if you need some promo

@jhakonen jhakonen added this to the Release 0.7 milestone Apr 26, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.