Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MongoDB tests not working behind proxy #627

Closed
fromi opened this issue Oct 1, 2014 · 10 comments

Comments

@fromi
Copy link

commented Oct 1, 2014

Behind a proxy flapdoodle embed mongoDB Downloader fails to download mongodb when unit tests are run. Library cz.jirutka.spring.embedmongo does not allow to configure proxy settings. Internal flapdoodle library have this feature.

Ideally, I would:

  • remove every tests implying MongoDB from Unit tests (maven test goal), to have them inside Integration test.
  • replace cz.jirutka.spring.embedmongo with com.github.joelittlejohn.embedmongo.embedmongo-maven-plugin to have mongoDB started once when integration tests start.
  • have embedmongo-maven-plugin reuse active maven proxy configuration by default.

Maybe I will create some pull requests if I achieve that.

@jdubois

This comment has been minimized.

Copy link
Member

commented Oct 1, 2014

@jmirc as you coded this part, is that OK with you?
Those projects seem more widely used (more Github stars), but I don't know them

@jmirc

This comment has been minimized.

Copy link
Member

commented Oct 1, 2014

I don't know too. I will check it. In the meantime if @fromi can provide a PR we will be able to test it and to integrate it. Thanks for the feedbacks

@jdubois

This comment has been minimized.

Copy link
Member

commented Oct 2, 2014

@fromi in fact this is an issue with cz.jirutka.spring.embedmongo not with your proxy (I have the same error, without using a proxy). It looks like MongoDB version 2.6.0 got deleted.
Anyway, upgrading cz.jirutka.spring.embedmongo solves the problem -> as long as this works, there is no need to migrate as far as I'm concerned, I hope you're OK with that

@jdubois jdubois closed this in a8a0756 Oct 2, 2014

@jdubois jdubois modified the milestone: 1.2.2 Oct 2, 2014

@fromi

This comment has been minimized.

Copy link
Author

commented Oct 6, 2014

Hi,
I am quite confident that the issue remains when using a proxy. There is no way to configure a proxy with current library.
I am working on some pull requests, I managed the two first bullet I listed previously, but the third one is harder.

@jdubois jdubois reopened this Oct 6, 2014

@jdubois jdubois modified the milestones: 1.2.2, 1.2.3 Oct 7, 2014

@fromi

This comment has been minimized.

Copy link
Author

commented Oct 7, 2014

I created 2 pull requests:

About reusing the proxy configuration from user settings.xml, I created a ticket on embedmongo-maven-plugin project: joelittlejohn/embedmongo-maven-plugin#39.

@jmirc

This comment has been minimized.

Copy link
Member

commented Oct 12, 2014

Thanks for your PR.

@jdubois

This comment has been minimized.

Copy link
Member

commented Oct 12, 2014

@jmirc don't merge now, they need to work with the entity sub-generator first (should be easy)

@fromi

This comment has been minimized.

Copy link
Author

commented Oct 12, 2014

The proxy problem is not really solved by pull request #653, but once MongoDB has been downloaded the first time by flapdoodle-embed-mongo, it is reused, so it is not a big issue.

@jmirc

This comment has been minimized.

Copy link
Member

commented Oct 21, 2014

you should remove the popup before any merge.

@jdubois

This comment has been minimized.

Copy link
Member

commented Oct 27, 2014

As the PR is closed, and that it's working with the older configuration, I'm closing this.

@jdubois jdubois closed this Oct 27, 2014

@jdubois jdubois modified the milestone: 1.5.0 Oct 29, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.