Skip to content

Log Forging Vulnerability

sendilkumarn published GHSA-pfxf-wh96-fvjc Jun 23, 2020
Severity
low
Packages
generator-jhipster-kotlin (npm)
Affected versions
1.6
Patched versions
1.7
CVE identifier
CVE-2020-4072

Impact

We log the mail for invalid password reset attempts.
As the email is provided by a user and the api is public this can be used by an attacker to forge log entries.
This is vulnerable to https://cwe.mitre.org/data/definitions/117.html

This problem affects only application generated with jwt or session authentication. Applications using oauth are not vulnerable.

Patches

TBD.

Workarounds

In AccountResource.kt you should change the line

 log.warn("Password reset requested for non existing mail '$mail'");

to

 log.warn("Password reset requested for non existing mail");

References

For more information

If you have any questions or comments about this advisory: