Permalink
Browse files

Make sure we only require CPANPLUS::Dist::Build as a prereq if it is …

…already installed and < 0.60
  • Loading branch information...
1 parent af44491 commit 0ba41761a113018b30f021c6b210cae00d4f4099 @bingos bingos committed Jan 30, 2013
Showing with 1 addition and 0 deletions.
  1. +1 −0 lib/CPANPLUS/Selfupdate.pm
@@ -72,6 +72,7 @@ CPANPLUS::Selfupdate - self-updating for CPANPLUS
'Parse::CPAN::Meta' => '1.4200', # config_requires support
'ExtUtils::Install' => '1.42', # uninstall outside @INC
( check_install( module => 'CPANPLUS::Dist::Build' )
+ && !check_install( module => 'CPANPLUS::Dist::Build', version => '0.60' )
? ( 'CPANPLUS::Dist::Build' => '0.60' ) : () ),
},

0 comments on commit 0ba4176

Please sign in to comment.