Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Run tests directly with python setup.py test

  • Loading branch information...
commit 883e687b2128fda0e421c03fac6bc16709f32f14 1 parent bae5dfa
@jimr authored
View
1  .gitignore
@@ -4,6 +4,7 @@ env
*.py[c,o]
*.bak
*.swp
+*.egg
*.egg-info
.DS_Store
.tox
View
1  README.rst
@@ -8,6 +8,7 @@ Currently only support ``--mill`` and ``--render``.
There are no requirements for Python 2.7, 3.2+, and pypy-1.9 unless you want to run the tests.
To run tests, first ``pip install nose testy`` and then just run ``nosetests``.
+Alternatively, just run ``python setup.py test``.
The remainder of the documentation is adapted from the original project.
View
2  projectmill/__init__.py
@@ -13,7 +13,7 @@
from __future__ import with_statement
__title__ = 'projectmill'
-__version__ = '0.2.1'
+__version__ = '0.2.2'
__description__ = 'Python port of https://github.com/mapbox/projectmill'
__url__ = 'https://github.com/jimr/py-projectmill'
__build__ = 0
View
4 setup.py
@@ -47,5 +47,7 @@ def get_init_val(val, packages=PACKAGES):
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Scientific/Engineering :: GIS',
],
- packages=PACKAGES
+ packages=PACKAGES,
+ test_suite='tests',
+ tests_require=['testy'],
)

0 comments on commit 883e687

Please sign in to comment.
Something went wrong with that request. Please try again.