Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 78 lines (68 sloc) 1.74 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77
require File.expand_path('../helper', __FILE__)

class TestRakeDsl < Rake::TestCase

  def setup
    super
    Rake::Task.clear
  end

  def test_namespace_command
    namespace "n" do
      task "t"
    end
    refute_nil Rake::Task["n:t"]
  end

  def test_namespace_command_with_bad_name
    ex = assert_raises(ArgumentError) do
      namespace 1 do end
    end
    assert_match(/string/i, ex.message)
    assert_match(/symbol/i, ex.message)
  end

  def test_namespace_command_with_a_string_like_object
    name = Object.new
    def name.to_str
      "bob"
    end
    namespace name do
      task "t"
    end
    refute_nil Rake::Task["bob:t"]
  end

  class Foo
    def initialize
      task :foo_deprecated_a => "foo_deprecated_b" do
        print "a"
      end
      file "foo_deprecated_b" do
        print "b"
      end
    end
  end

  def test_deprecated_object_dsl
    out, err = capture_io do
      Foo.new
      Rake.application.invoke_task :foo_deprecated_a
    end
    assert_equal("ba", out)
    assert_match(/deprecated/, err)
    assert_match(/Foo\#task/, err)
    assert_match(/Foo\#file/, err)
    assert_match(/test_rake_dsl\.rb:\d+/, err)
  end

  def test_no_commands_constant
    assert ! defined?(Commands), "should not define Commands"
  end

  def test_deprecated_object_dsl_with_suppressed_warnings
    Rake.application.options.ignore_deprecate = true
    out, err = capture_io do
      Foo.new
      Rake.application.invoke_task :foo_deprecated_a
    end
    assert_equal("ba", out)
    refute_match(/deprecated/, err)
    refute_match(/Foo\#task/, err)
    refute_match(/Foo\#file/, err)
    refute_match(/test_rake_dsl\.rb:\d+/, err)
  ensure
    Rake.application.options.ignore_deprecate = false
  end
end
Something went wrong with that request. Please try again.