Permalink
Browse files

Restrict rake to minitest ~> 4

Rake is included in ruby which is only up to minitest 4.x, not minitest
5.  If minitest 5 features are used rake's tests will not run after an
import into ruby.
  • Loading branch information...
1 parent 34f3bfd commit b0c5a251838555d5a2fc7d9541608a7e984522ea @drbrain drbrain committed Oct 11, 2013
Showing with 2 additions and 2 deletions.
  1. +1 −1 Rakefile
  2. +1 −1 test/helper.rb
View
@@ -171,7 +171,7 @@ specified in standard Ruby syntax.
s.required_ruby_version = '>= 1.8.6'
s.required_rubygems_version = '>= 1.3.2'
- s.add_development_dependency 'minitest', '~> 2.1'
+ s.add_development_dependency 'minitest', '~> 4'
s.files = PKG_FILES.to_a
View
@@ -2,7 +2,7 @@
$:.unshift File.expand_path('../../lib', __FILE__)
begin
- gem 'minitest'
+ gem 'minitest', '~> 4'
rescue Gem::LoadError
end

0 comments on commit b0c5a25

Please sign in to comment.