Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

0.7.6

update files for 0.7.6 release

0.7.5

update files for 0.7.5 release

0.7.4

update files for 0.7.4 release

0.7.3

bump files for 0.7.3 release

0.7.2

update files for 0.7.2 release

0.7.1

bump versions for 0.7.1 release

0.7.0

updates for 0.7.0 release

0.6.8

update changelog and gemspec for new release

0.6.7

prepare for 0.6.7 release

0.6.6

update changelog and gemspec for 0.6.6 release

0.6.5

bumping version, updating gemspec for 0.6.5 release

0.6.4

mention Yajl.load/Yajl.dump in changelog

0.6.3

Fixed a bug in the JSON gem compatibility API where strings weren't b…
…eing properly escaped

0.6.2

Fixed a bug with double-quoted strings when another library provided …
…it's own to_json method (like ActiveSupport). Closes GH #5 and #6

0.6.1

updating files for 0.6.1 release

0.6.0

updating files for release

0.5.12

changing readme to previously used verbage

0.5.11

updating files for 0.5.11 release

0.5.10

Merge branch 'master' of git@github.com:brianmario/yajl-ruby

0.5.9

updating files for 0.5.9 release

0.5.8

updating changelog, gemspec and internal version for new release

0.5.7

updating files for 0.5.7 release

0.5.6

updated files for 0.5.6 release

0.5.5

updated benchmarks for Marshal.load/dump to fix multiple iteration pr…
…oblems

added C documentation for the JSON compatibility API functions
bumped the internal version, updated changelog, readme and gemspec for 0.5.5 release

0.5.4

updating gemspec for 0.5.4 release

0.5.3

updating gemspec for 0.5.3 release

0.5.2

updating gemspec and readme for 0.5.2 release

0.5.1

updated changelog, internal version and gemspec for 0.5.1 release (mo…
…stly just to rebuild the gem with the latest stuff)

0.5.0

updating changelog for release date

0.4.9

updating gemspec to try and trigger a build

0.4.8

prepping files for 0.4.8 release

0.4.7

adding Lloyd as an author since his sources are bundled now

0.4.6

updating gemspec for 0.4.6 release

0.4.5

Regenerated gemspec for version 0.4.5

0.4.4

updating gemspec for release

0.4.3

pushing updated changelog and gemspec for 0.4.3 release

0.4.2

updates for 0.4.2 release

0.4.1

updating gemspec for 0.4.1 release

0.4.0

updating gemspec for 0.4.0 release, minor update in how yajl was bein…
…g required in spec_helper.rb

0.3.4

* turned Unicode checks back on in the Yajl parser now that it's fixe…
…d (thanks Lloyd!)

** this also bumps the yajl version dependency requirement to 1.0.4
* better guessing of Integer/Float from number found instead of just trying to create a BigNum no matter what
* changed extconf.rb to fail Makefile creation if yajl isn't found
* added a test to check for parsing Infinity due to a Float overflow

0.3.2

updating changelog for 0.3.2 release

0.3.0

changes for 0.3.0 release

0.2.1

Fixed parsing bug
failing ActiveSupport test cases now pass (with the exception of the one, which is an issue in Yajl itself)
Something went wrong with that request. Please try again.