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1. Setting up a Console Application in VC 10

(D Create a Console Project(Zil H)
2 Solution(#£) Explorer

@ Add New Source File

4 Add Code

® Class View

©® Setup Intermediate Directory (Optional)
@ Build Project

Run the Program
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Step 1: Create a Console Project

Choose File -> New -> Project from the VS210 menus => Win32 Console Application (chosen from the
templates on the right side).

Set the location to someplace on your drive and give the project a name, such as A_Console Project.
Click OK.

. Go to the Application Settings tab. Make sure Console application and Empty project

are selected.

. Click Finished.
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Step 2: Solution Explorer

Remesh - Microsoft Visual Studio

1. Choose View- Solution Explorer from the VS e,
File Edit View Qt Proect Build [
MENus G A S| 6o A
b A MR EEE| S 2 |C
2. It shows you a tree representing your current ryr——— e
solution. =

A Solution 'Remesh’ (3 projects) -

. Solution Items

3. Solutions are made of one or more projects, Which [ | = \..chingcube
In turn are composed of one or more files. We B Meshio 3
currently have one project in our solution, namely e mal Dependenic
A _Console Project [ Header Files

_1 Resource Files

4 | Source Files -
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Step 3: Add New Source File

. Right click on our project A_Console_Project at solution explorer and choose Add->Add New Item.
. We want a C++ source file so choose the Code category and C++ File (.cpp) from the Templates.
Enter a name for our source file, main.cpp in our case. The location should already be under the project

you’'ve created.
Click Add.

. You should now see a blank source file in the editor titled main.cpp.
Solution Explorer shows that A_Console_Project has currently a single file main.cpp under Source

Files.

Add New Item — A Console_Froject

Categories: Templates:
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Step 4: Add Code

Enter the following code into main.cpp which should already be open in
the main source window.
#include <iostream>
using namespace std,;
Int main(int argc, char** args){
cout << "Hello world" << endl,
return O;



Step 5: Class View

1. We have a single function: main() currently, so it is easy to locate the

code. However, the project can become rather large and finding the e
function you want to modify may not be so easy. <Search> Ja =
2. Choose View -> Class View => Class View window, which is similar to <= Yercrinscee :

= Macros and Constants

Solution Explorer. Hence you'll probably want to place them together. “ 92”7

¢ IsoSurface<short=

3. It breaks the project up by class and function rather than by file. Right = *ESEEaS

*2 NonobtuseMC =short=

now we have only a single function main but later your projects will 0 Momolmanhc<1a
grow to multiply classes each containing many functions. The Class o ey
View window will prove invaluable when navigating such projects later & tiettodintype
In the course. 5 Meshio
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Step 6: Setup Intermediate Directory
(Optional)

1. Open the Class View window, right click on our project A_Console Project and choose
Properties. Select General from the left hand pane and set the Output Directory and
Intermediate Directory both to C:\Temp\Debug.

2. Click OK and we're all set to compile our project.

A Console_Project Property Pages

Configuration; |Actiwve (Debug) % | PFlatform: |Actiwve (fin32) W [
Common Froperties B General
=) Configuration Properties Output Directory C:\Temp\Debug
G—enera:!_ Intermediate Jirectory C:\TempiDebug
Debuzzing _ _ _ .
CACH Exten=zion= to Delete on Clean #. obj % 11k % t1b; . 14

Linker Build Log File F (IntDir)'Buildlog htm



Step 7: Build (compile+link) Project

1.View->Other Windows->Output from VS2010 menus. The Output window shows the output
from the compile and linking process.

2.Chose Build->Build Solution (F7) from the VS2010 menus.
3.1f you've copied the code correctly, you should see the following output to the right.

4.1f the build failed you should see some text explaining why it failed. If the erroris a compiling
error, you should be able to double click on the error and the source window should update to
show you the line on which the error occurred.

Output

Show output from: | Build - H || =K | =

17— Build started: Project: A Console Project, Configuration: Debuﬁ Wipd? —————

17Build sharted 2011/8/23 9:59:23.

1¥nitializeBuildStatus:

1» Creating “C: 4" Temp'Debughh_Conzole_Project. mmenccessfulbuild” becauze “AlwaysCreate” waz specified
1oClonnile:

1» win32Ceonzole. cpp
1ManifestResourceCompile:

1» A1l ocutputs are up—to-date.
1Manifest:

1> Al outputs are up—to—date.
1:LipkEmbedlani fest:

1> A1 outputs are up—tn—datew
1> A Comzole_Froject. wexproj —# C:\TemE\DebuE\A Conzole Project. exely
1 FinalizeBuildStatus:

1» Deleting file “C:‘\TemphDebug'h_Conzole_Froject. unsuccessfulbuild”
1» Touching “C:\TempiDebughh Conzele Froject. lastbuildstate”

1

17Build succeeded

1

1>Time Elapsed 00:00:02. 21

========== Build: 1 succeeded 0 failed, 0 up—to—date, 0 skipped ==========
A ——




Step 8: Run the Program

* Place a breakpoint on the line “return 0” by left clicking on the position of the big
red point (left click again, it will disappear) and press F5.

« A console window appears and the program will break at the line “return 0”.

* Press F5 again to continue the execution of the program, and the program will
exist successfully.

T
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mAln. Cpp

(Global Scopel

finclude <iostream”
using namespace std;
lint main(int arge, char**% args) |
cout << "Hello world” << endl:
=] return 0;
/ | “ | i\‘ ‘ul 9 M‘ %1 M‘ - B u (. | ‘LJ ; v czytempidebugiA Con=ole_ Project. exe S| ﬂ
- Hello world B




Questions?
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2. Command Line Argumentii ${TS

1.In Windows, the GUI will be used to communicate with the user.
2.In DOS, command line arguments are used to parse in users' specified parameters.

3.In the following figure, "Command _line_argument.exe" is the command and | am
JJCAO is the command line arguments being parsed in.

1. |\/|0d|fy Main B C\Windows\system32\cmd.exe
2. Modify Project's Command
Arguments C:slserssjjcaoicd cistemp™debug
3. Build Project c i Temp“Debug>Command_line_argument.exe I am JJCAD

4. Run the program 1th argument is I

2th argument is am
3th argument is JJCAD

c = ~Temp“Debug



Step 1: Modify Main

#include <iostream>
using namespace std,;
Int main(int argc, char** args)

{
// Notice | start from i=1 not O because the args|0] is reserved
/] for the name of this program.

for(int 1 =1; 1< argc; i1++)

{

cerr << i << "th argument is " << args[i] << "\n";

}

}

Note: The relationship of argc and args:

1. argsis an array of char*

2. argc is the size of the array: args, which is determined when command line arguments are
passed to the main() function. So after you change the size of args, argc is not updated
automatically.



Step 2: Modify Project's Command
Arguments Setting

Open the Class View window, right click on our project (Command_line_argument), and choose
Properties. Choose Debugging from the left hand pane. Add My name is JJCAO to the Command
Arguments. Click OK

Command_line_argument Property Pages

Configuration: ‘Active{[ﬁlebug] + | Platform: |Active(Win32)

Debugger to launch:

- Common Properties

« Confioucation Proggrties |Local Windows Debugger

General
Debuggin
e L . Command $(TargetPath)
Intel Performance Librar -
, , Command Arguments ME name is JJCAQO
VC++ Dhrectones

Working Directory $(ProjectDir]

S i T



Step 3: Build Project

* Press F7 to build the solution.

Output
Show output from: |Build - | H | & | = | (=]
1 - Build started: Project: Command line argument, Configuration: Debug Windsd ————-

1Bnild started 2011/8/23 10:09:35.
13 InitializeBuildStatns:
1% Creating "C:h\TemphDebug'Command line argument. unsnccessfulbuild” becanze “AlwaysCreate” was specified.

1C1Compile:

1% commandLine. epp

1 *LinkEmbedMani fest:

1% Command_line argument. wexproj —# C:hTemp'DebuzghCommand line argument. exe
1*FinalizeBuildStatus: e

1% Deleting file "C:\TempiDebug'Command line argument. nnsuccessfulbnild”.
1% Tonching "C:hTemphiDebug'Command line arzument. lastbuildstate”™.

1%

1%Build =suceceeded.

1

15Time Elapsed 00:00:03. 00

========== Build: 1 succeeded, 0 failed, 0 up—to—date, 0 skipped ==========



Step 4: Run the Program

* Press F5 to run the program..
« Congratulations! You've got your 2nd successful VS2010 project

i CATemp\Debug\Command_line_argument.exe

Hl

argument
arqgument

u Hl

arqgument
argument

-
e I I B

Hl

Note: When debugging a c++ program from the IDE (F5), the current path is
the path where the project file (*.vcproj) is located. When running a c++
program from the IDE (Ctrl+F5), the current path is the path where the excutable
file (*.exe) is located (commonly is the path Debug).



Questions



Input

 Let user input values to the program (line 6)

e ctrl+z: cancel input from cin

o

T = o

9
10
11

#include <i1io0ostream>

using namespace std;

int main() {
1nt x;
cin >> X;

cout << x / 3 <<

return O;

]

<< w ok D¢



iostream

* Cin

* cout

* cerr

* clog

 Ordinarily, sys associates them with the console window.
* They can be redirected to files.



Default current directory of VC

* Solution: O1-Introduction
* Project: A_Console Project
* Project: Command_line_argument
4 | 01-introduction
. A_Console_Project
. Command_line_argument
. Debug
« Current Project: Command_line_argument
* The current directory of the current project

* The dir where the Command_line_argument.vcxproj is

* Where is win32Console.cpp?
../ A_Console_Project/

Solution Explorer > 1 x

= 2| Ea
) Solution '01-introduction’ (3 projects)
4 [J1 A Console_Project
+ [ External Dependencies
1 Header Files
[1 Resource Files
4 |7 Source Files
¢+ win32Console.cpp
4 71 Command_line_argument
- [ External Dependencies
[[1 Header Files
[1 Resource Files
4 | Source Files
¢ commandLine.cpp

Clean

Project Only

Calculate Code Metrics
Profile Guided Optimization
Project Dependencies...
Project Build Order...

Build Customizations...

Add

References...

Class Wizard...

& B

View Class Diagram

Set as StartUp Project
Debug

Add Solution to Source Contraol...

e



Debugging

« Compilation error
* Violations of the syntax rules
« Misuse of types

 Runtime error
* Need debugging



Seft include & lib path independent with
solutions |

Set it In Property Manager (You have to open a project
first.) If you set it in the Context Menu of a solution or |
project, it will be dependent on specified projections.

Property Manager...t.Cpp.Win32.user » A

a|at| e ¢ |d

4 [7] MarchingCube
4 [/ Debug | Win32
Ea_MichEDﬂ.Cpp.WirE." e
Unicode Support :# Add MNew Project Prope
= Core Windows Libra 2

4 [ Release | Win32

Microsoft.Cpp.Win3.

m Opt

Add Existing Property § _!

Mowe Later in Evaluatio

‘Move Earlier in Evaluati
4 Comman Properties

Save Microsoft.Cpp.Wir

General

Unicode Support

View Ot Project Build Debug Team
&3 Solution Explorer Ctrl+Alt-
-Eﬁ Team Explorer Ctrl+Y, C
=] Architecture Explorer Ctrl+Y, C
2 Bookmark Window Ctrl+K, €
1[5} call Hierarchy Ctrl+Alt-
] % Class View Ctrl+5Shif
& Code Definition Window Ctrl+5Shif
. =Y Object Browser Ctrl+Alt-
' & Error List Ctrl+y, E
[l 5 Output Alt+2
H Resource View Ctrl+Shil
B Start Page
3 Toolbox Ctrl+Alt-
Find Results
Other Windows
Toolbars
=l Full Screen Shift+Alt
v 5 MNavigate Backward Ctrl+-
2, Mavigate Forward Ctrl+Shil
Mext Task
Previous Task
=;| Property Manager—j

=|

4
${(VClnstallDir)bin:$ (Winc

= User Macros Inghude Cirectoges S(OPENCY_DIFY\dndud
'!_=| Core Windows Libral #¢ Remove Irtel Perfarmance Libeas F:Mrfﬂ $IVClnstallDhe) atherc Bb:
- 7] MeshParser Rename s Do ibran Diectori EPCY DAV,
: ::3 Test ._='| PrDPEI‘liEE - Lackr Exclude Dhrectones SVCInstallDvrlinclude: S0

r -

Property Pages



Build configurations
« Switching between debug and release in Visual Studio

Dd ConsoleApplicationl - Microsoft Visual Studic (Administrator)
FILE EDIT VIEW PROJECT BUILD DEBUG TEAM TOOLS TEST ANALYZE WINDOW  HELP

B3-2 WM - - | P Local Windows Debugger ~ E;Auto i

11



Pack Your Solution
-- before sending it to others

Delete *.ncb || *.sdf

Delete debug, release && ipch directories
Compress all into a *.rar or *.zip

Sent it by emall || ...

> w N

—_
%

F33T8 T Bpacking.bat



https://github.com/jjcao/jjcao_code/blob/head/packing.bat

HEC++I[FIZESE

* http://www.runoob.com/cplusplus/cpp-environment-setup.html




