Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Update polkit policy: use auth_admin for all, add message & icon

  • Loading branch information...
commit 3e5a4bcaf2ed4bebb7ae132ddd7f34ae78ebdd85 1 parent 5479647
jjk-jacky authored

Showing 1 changed file with 4 additions and 2 deletions. Show diff stats Hide diff stats

  1. 6  org.jjk.kalu.policy
6  org.jjk.kalu.policy
@@ -8,9 +8,11 @@
8 8
 
9 9
   <action id="org.jjk.kalu.sysupgrade">
10 10
     <description>Upgrade all packages that are out of date (same as `pacman -Syu`)</description>
  11
+    <message>Authentication is required to start a full system upgrade via kalu's updater</message>
  12
+    <icon_name>kalu</icon_name>
11 13
     <defaults>
12  
-      <allow_any>no</allow_any>
13  
-      <allow_inactive>no</allow_inactive>
  14
+      <allow_any>auth_admin</allow_any>
  15
+      <allow_inactive>auth_admin</allow_inactive>
14 16
       <allow_active>auth_admin</allow_active>
15 17
     </defaults>
16 18
   </action>

0 notes on commit 3e5a4bc

Please sign in to comment.
Something went wrong with that request. Please try again.