New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test failure with perl 5.26.0 #1

Open
eserte opened this Issue May 12, 2017 · 2 comments

Comments

Projects
None yet
1 participant
@eserte

This comment has been minimized.

Show comment
Hide comment
@eserte

eserte Aug 11, 2017

This issue is still open with version 0.008.
It fails (of course) also with the current bleadperl 5.27.2.

eserte commented Aug 11, 2017

This issue is still open with version 0.008.
It fails (of course) also with the current bleadperl 5.27.2.

@eserte

This comment has been minimized.

Show comment
Hide comment
@eserte

eserte Aug 11, 2017

It fails (of course) also with the current bleadperl 5.27.2.

Well, this is wrong. It fails only with 5.26.0. With perl 5.27.2 it's just a warning (but it should be corrected nevertheless):

Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/div { <-- HERE  border: 1px }/ at t/catalyst.t line 18.

eserte commented Aug 11, 2017

It fails (of course) also with the current bleadperl 5.27.2.

Well, this is wrong. It fails only with 5.26.0. With perl 5.27.2 it's just a warning (but it should be corrected nevertheless):

Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/div { <-- HERE  border: 1px }/ at t/catalyst.t line 18.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment