Skip to content
Browse files

Fixed run_pyhole.sh and the new pyhole executable and updated the REA…

…DME to reflect the recent changes
  • Loading branch information...
1 parent 12d4d11 commit 616c263168c826d248030b8bffedd6f784724b15 @justinwyer justinwyer committed Aug 22, 2013
Showing with 30 additions and 30 deletions.
  1. +0 −28 README
  2. +28 −0 README.md
  3. +1 −1 setup.py
  4. +1 −1 tools/run_pyhole.sh
View
28 README
@@ -1,28 +0,0 @@
-pyhole - A modular IRC bot for Python developers.
-
-
-Core Requirements
-
- - Python 2.5+
- - BeautifulSoup
- - Eventlet
-
-
-Plugin Requirements
-
- - launchpadlib
- - pywunderground
-
-
-Test Requirements
-
- - nose
-
-Installation
-
- git clone git://github.com/jk0/pyhole.git
- cd pyhole
- sudo pip install -r tools/pip-requires
- ./tools/run_pyhole.sh
- vi ~/.pyhole/pyhole.conf
- ./tools/run_pyhole.sh
View
28 README.md
@@ -0,0 +1,28 @@
+pyhole - A modular IRC bot for Python developers.
+
+
+Core Requirements
+
+- Python 2.5+
+- BeautifulSoup
+- Eventlet
+
+
+Plugin Requirements
+
+- launchpadlib
+- pywunderground
+
+
+Test Requirements
+
+- nose
+
+Installation
+````
+git clone git://github.com/jk0/pyhole.git
+cd pyhole
+sudo pip install -r requirements.txt
+python setup.py install
+pyhole
+````
View
2 setup.py
@@ -41,7 +41,7 @@ def requirements():
"Programming Language :: Python",
],
entry_points={
- "console_scripts": ["pyhole = pyhole.irc:main"]
+ "console_scripts": ["pyhole = pyhole.client:main"]
},
setup_requires=['nose>=1.3.0']
)
View
2 tools/run_pyhole.sh
@@ -14,4 +14,4 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-python -c "from pyhole import irc; irc.main()" $@
+python -c "from pyhole import client; client.main()" $@

0 comments on commit 616c263

Please sign in to comment.
Something went wrong with that request. Please try again.