Rails 3.1 fix doesn't work in Rails 3.2 #33

Closed
nirvdrum opened this Issue Jan 19, 2012 · 0 comments

Projects

None yet

2 participants

@nirvdrum
Collaborator

In lib/analytical/api.rb there is a check for Rails 3.1 like so: if ::Rails::VERSION =~ /^3\.1/

The same Rails 3.1 codepath should probably be run for all versions > 3.1, but the check as it is will only work with 3.1.x. So Rails 3.2 executes the old path and raises a bunch of deprecation warnings.

@jkrall jkrall added a commit that closed this issue Jan 22, 2012
@jkrall Fixed Rails version check so it works with 3.2
Closes #33
Closes #34
9de8957
@jkrall jkrall closed this in 9de8957 Jan 22, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment